Xcode 9.2 app uploading broken?

Just installed Xcode Version 9.2 (9C40b) from the App Store.

I've got a critical bug fix I'm trying to upload and release but I keep getting

ERROR ITMS-90534: "Invalid Toolchain. New apps and app updates must be built with the public (GM) versions of Xcode 6 or later, macOS, and iOS SDK or later. Don't submit apps built with beta software including beta macOS builds."

Which is crazy as I'm using the official Xcode and not any beta.

I don't use beta's so it's not anything legacy.

Only yesterday I successfully built and uploaded to ITC a build for the same app which is now in Test Flight.

Yesterday I was using Xcode 9.1, today Xcode 9.2

I tried using the Application Loader Version 3.7 (1034) but it gives the same error even though it allows you to ignore the error and Send anyway it still doesn't work.


I have just updated to Xcode 9.2 via the App Store and I'm on a non-beta version of macOS and I am also getting the same error when I try to upload my builds to iTunes Connect.

Doing a quick bit of research it could be caused by the security updates recently released by Apple but I'm not too sure.

I am getting exactly the same issue after updating to xcode 9.2 (9C40b).

It looks like a bug on apple's side. The iTunes connect guys are probably still treating the new production xcode as a beta version.

Except the beta version let me upload yesterday 😉

Oh the joy of having 2 Macs. My MacAir still has 9.1 on it so I fired it up, compiled the binary and uploaded no problem.

I suspect someone hasn't made the necessary config changes to ITC to allow it to accept submissions from xc9.2

No doubt tomorrow this will have resolved itself quietly.

Did this get fixed yet? I want to download 9.2 so I can deploy to my iOS11.2 phone but I have to submit tomorrow so can't risk it. Now I have to test and debug AR stuff on an iPad (still on 11.1)

I didn't realise only half an hour had passed. It's the 5th already here! I'll check back in the morning.

Happens all the time - sort of a left hand/right hand thing. Give it another day, then try again.

Same issue - I updated to 9.2 so I could run my app on my device with 11.2, also noted it here: https://stackoverflow.com/questions/47644270/xcode-9-2-upload-to-app-store-fails-with-description-length-and-invalid-toolchai

same problem

iTunes Connect hasn't been updated to accept Xcode 9.2 for uploads to the store. This is not an unusual issue, and the solution is always the same - be patient until the proper flag is set on the backend. I'd expect it with the next 24 hrs.

Be sure to check here as I'm sure someone will alert the community when it's clear to use v9.2

Hello guys, I urgently need to upload my app and I am stuck with this error as well, if I have this Xcode Version 9.2 (9C40b), is there something I can do using my same computer to upload my app? Is it possible to install an xcode version that wil l work right now?

Xocde v9.1 should work, in general. Just be sure to create a fresh build with it first so that project/app doesn't smell like v9.2 when it gets to the store.

And if you don't still have a working v9.1 install, you can get it here: https://developer.apple.com/download/more/

Be careful when you install it...there may be a naming conflict w/9.2

As suggested by KMT, I completely uninstalled XCode 9.2 (using MacCleaner's uninstaller utility), downloaded Xcode 9.1 from

https://developer.apple.com/download/more/ , installed it, added my account again from Xcode/Preferences/Accounts and then simply went to Product/Archive and it was uploaded flawlessly.

Good info, thanks for the update and good luck in the store.


Exactly the same issue after updating to xcode 9.2 (9C40b).