iOS 12 GPS not working.

AT&T or Wi-Fi GPS not working On iOS 12 anyone else having this issue? If so is there anyway to fix it. I’ve tried everything I can think of to fix it nothing works.

Post not yet marked as solved Up vote post of slush23 Down vote post of slush23
29k views

Answers

I’m using iPhone X

I'm having the same issue. Some have had luck restoring the phone...I did not. The only thing I have found to semi work is to open multiple apps that use GPS (pokemon go, apple maps, google maps, Jurassic World Live). I have found that after a while once it gets a gps lock, then they all work fairly well. It is almost like the slate is wiped clean and each time you open a GPS app it needs to fix and take a long time to acquire satellites.

I too have an iPhone X and am experiencing the same issue and the same work around. After I open Apple Maps, Google Maps and Waze things start to work. Has any one opened a ticket yet?

to get more information try an App

GPS diagnostic or GPS data


When there is no starting sat data for orbits or current location it took 10 to 15 mins on old Garmin GPS units to get a 3 sta fix.

I did a full restore to 12b1 via iTunes on my iPhone X. Today the navigation with Google Maps went flawlessly: quick GPS fix, no stuttering, no loss of GPS fix anymore. No issues anymore.

Thomas, how did you do the restore? Maybe I am doing it wrong. I received an error when trying to do the restore from iCloud through iTunes, but was able to do a restore that appeared to say something like "just files and not operating system"

Hi DanaJets,

You have to backup your iphone to your local drive (encrypted, not to iCloud) first, then restore using the ipsw file and press the option key while clickling "restore" in iTunes. Then you can select the ipsw file from the location where you stored it.

Once the iOS is installed you connect it to iTunes and you can select to set it up as new or "restore" from the previously made backup.

It takes a while until all docs, settings and apps are reinstalled.

Hope this works for you.

Thomas, that was it thank you! I ran the previous from the OTA so I didn't have the IPSW downloaded. I will download and retry when I get home. Appreciate the assist.

Not my luck today...just renewed my account and i am getting the link for the downloads, however it says "The Apple ID you signed in with does not have permission to view this page."


Guess I will try again later.

Got it to work finally and I can confirm that the restore fixed the gps issue.

I am havimg the same issue on iPhone 8 Plus. It’s not that it does not work completely. It’s just like 10 years ago when there was no assisted gps and i had to download ephemeric data to my htc artemis :). So If I wait couple minutes in a good location. It starts to work. I dont want to do backup and restore because that would mean to setup all banking apps etc.

I reset the Locaton & Privacy settings and this re-enabled the GPS for Waze and Maps for me.


Reset Location & Privacy

If the GPS problem persists, try resetting Location & Privacy settings on your iPhone.

  1. Go to Settings » General » Reset.
  2. Select Reset Location & Privacy.
  3. You’ll be asked to enter a passcode (if applicable), tap on Reset Settings to confirm your action.

I have tried this numerous times and cannot resolve the problem with my location not being detected. This is affecting all of my navigation apps as well as my workout apps. In addition, I have to go into airplane mode and use GPS on my watch or my watch will not reflect distance during a workout using the Fitness Apple Watch app. Has anyone figured out a way to reset GPS connectivity?

I have a A1901 on T Mobile. GPS was slow to acquire on Beta 1 (which I acquired via OTA update) - normally at least 6 minutes. After locking was normally completely stable/normal. In efforts to fix it I reset Network Settings and Location and Privacy. None made a noticeable difference.

Beta 2 (OTA Update) made the GPS worse. Frequently took a half hour to acquire and then was prone to dropping.

What has fixed mine (at least for today) was using IPSW file which I got from IPSW for A1901 This file is 3.41GB where the other IPSW files I tried were much smaller - I am guessing the larger file is the complete OS where the other smaller ones are updates to a base it expects the phone to have. I could be wrong on that aspect and would appreciate correction if that's the case.

At any rate I installed the IPSW using iTunes. No reset of anything. As soon as the phone booted I launched Waze and already had solid GPS. I have used Waze for a couple of hours since on several trips, killing and relaunching the app each time. Every time the GPS was there as soon as the app loaded.

My only guess is some part of the Beta 1 OTA failed to update something or updated improperly. The OTA for Beta 2 likely didn't include whatever was broken but the larger/complete IPSW did.

I hope this helps someone and if any of my assumptions are incorrect I'd appreciate being corrected.

im having same issue also with gps not working, im using iphone 7 plus