Xcode 10 beta 4 - stdlibc++ headers not found;

I get this warning compiling Tesseract OCR engine on beta 4.


warning: include path for stdlibc++ headers not found; pass '-std=libc++' on the command line to use the libc++ standard library instead [-Wstdlibcxx-not-found]

After the warning I get an error <string. or <vector> not found.

Can anyone help? What exactly do I need to do to move forward?

Worked fine with beta 3 (and for the last 10 years). If I try to edit the file Xcode then crashes.

Post not yet marked as solved Up vote post of marinercoder Down vote post of marinercoder
47k views

Answers

If anyone else has this issue, there is a a setting in build setting for which will set which c++ libraries to use (libc++ is now default). in my case I simply changed the minimum system to something recent, Xcode then will seset the critical bits for you.

For anyone else encountering this issue, I was encountering it because one of my project's frameworks was still using the old "libstdc++" library which is now unsupported in Xcode 10. I had to go into the framework's Build Settings, scroll all the way down to "Apple Clang - Language - C++" and change the C++ Standard Library from "libstdc++ (GNU C++ standard library)" to "libc++ (LLVM C++ standard library with C++11 support)"

I also encountered such a problem, but I solved it like this.

copy from


/Applications/Xcode9.4.app/Contents/Developer/Platforms/iPhoneOS.platform/Developer/SDKs/iPhoneOS.sdk/usr/include/c++ to Xcode10 the same path


Xcode10 had deleted it.


also,you should copy simulator c++ files.


hope that it works.

good luck.

To solve this problem completely, I needed to copy the following libraries as well as the headers:

libstdc++.tbd, libstdc++.6.tbd and libstdc++.6.0.9.tbd

in /Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/Developer/SDKs/iPhoneOS.sdk/usr/lib.

Thx.

Could you explain your solution better?


I get that you have found

these files:

libstdc++.tbd, libstdc++.6.tbd and libstdc++.6.0.9.tbd


here:

Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/Developer/SDKs/iPhoneOS.sdk/usr/lib.


move to:

[INSERT DIRECTORY (...I am dumb I am sorry...)]

I copy file but not run.

How can I copy the simulator files? Where is it? Could you help me?

Same problem happened to me, i just upgrade to 10.15 beta and install libc++

via brew. Hope it's working for you too.