iPad external keyboard spacebar not working properly

Hi,


Recently I installed iPadOS public beta and bought an external third party keyboard. The spacebar of the keyboard does not work properly on some applications including the native email app. When I clicked on the spacebar, it inputs newline instead of space. Also, I noticed I can input space by clicking on shift+spacebar or alt+spacebar.


I tried with another keyboard and same issues persists. Is this an issue from iPadOS public beta?


Anyone experiencing the same issues?

Post not yet marked as solved Up vote post of weilong1113 Down vote post of weilong1113
17k views
  • I use the fixing method as suggested and it worked but only for spacebar. My Tab key still have the same issue in Numbers app. I need to Alt Tab to move to next cell in Numbers. Any way to solve this. Also does this work normally if i use Apple keyboard instead? Other than that the keyboard is working fine.

  • The solution offered, to clear the space command, works for me. I also had to clear the commands for “Move Up”, “Move Right”, “Move Down” and “Move Left” to get my arrow keys to work (Zagg Folio keyboard, iPad Mini 4, iPadOS 15 Beta 8). I suggest that you also try clearing your Tab key’s command and any other commands that are not working for you.

Add a Comment

Answers

I have exactly the same issue! Even when I am writing this message here I still need to press SHIFT+SPACEBAR to stop one word and go to the next one... So frustrating... Please find a fix, because the writing is almost impossible in so many apps, specially in “google search” in Safari - spacebar makes Enter instead... In addition to this sometimes when you press the spacebar it appears a rectangle around the typing field..

Same here

Same here, I thought my smart keyboard was bad at first, tried a new keyboard and still the same problem.

Same problem. Also I noticed that when I press CTRL+tab a box appears swithcing around parts of webpage, or in general buttons of the app I am using.

Same issue here. I'm wondering if it's specific to 3rd party keyboards (vs Apple's Smart Keyboard Folio)? I've also tried with multiple (non-Apple) bluetooth keyboards.
Hope this will be resolved in the final release.

UPDATE: The issue is fixed after updating to public beta 3. Spacebar now works just like expected.

This is still not working on some websites in safari, space bar is treated as return.


one example is the search bar on google.com


hardware: smart folio for iPad pro 11

Guys

I just solved it disabling "full keyboard access". Hope this works also for you.


cheers


p.s. I have a bluetooth microsoft keyboard.

Thanks! This works to me.

And a bit more, you can just clear the shortcut for Spacebar under the "full keyboard access>>Commands" (it was set as act of Activate by default), don't need to disable the full function in case you need other shortcut to control the ipad.

  • Same issue with same solution. Thank you very much.

Add a Comment

I Had the same problem. Drove me crazy. Went to Settings: Accessibility: Keyboards: Full Keyboard Access: Commands: Activate: and then pressed "Clear" worked.

I had the same issue especially when using OneNote where pressing space was causing the command to do an 'Undo'.

I manage to fix my issue by going into 'Settings > Accessbility > Keyboards > Full Keyboard Access > Commands', and from there in the 'BASIC' section, I removed the 'Space' in the 'Activate' option.

I'm using a Smart Keyboard with a wireless mouse.

Hope this helps most of you!
  • IOS v13.5.1 on an iPad Pro 4th Gen -

  • Thank you so much! On my 3rd 3rd party keyboard. Your fix did the trick!!! So happy now!!!

Add a Comment
You can leave “Full Access Keyboard” on & just go to the “Commands” page under Accessibility -> Keyboards -> Full Access Keyboard & turn off “Activate” via space. Quit & relaunch your app. It worked for me with iVim / Vim.

Hope this helps!

Had the same issue with a 4th generation Ipad air with the magic apple keyboard.

Settings - Accessibility - Keyboards - Full Keyboard access - commands - Activate - Clear

worked for me.
  • Exactly the same with me. IPad Air 4, Apple magic keyboard (plus two other Bluetooth keyboards) exhibiting edit inhibiting results when keys pressed. The Settings-Accessibility-Keyboards-Full Keyboard Access-Commands-Activate-Clear eliminated the problem. Hopefully, this will be fixed in a future beta release so that keyboard full access can be used without issues.

Add a Comment
'Settings > Accessbility > Keyboards > Full Keyboard Access > Commands', and from there in the 'BASIC' section, removed the 'Space' in the 'Activate' option.



You guys always have the answer! Clearing the activate in the full keyboard access works perfectly fine. Thank you guys for doing the work!
  • I have exactly the same issue! Even when I am writing this message here I still need to press SHIFT+SPACEBAR to stop one word and go to the next one... So frustrating... Please find a fix, because the writing is almost impossible in so many apps, specially in “google search” in Safari - spacebar makes Enter instead... In addition to this sometimes when you press the spacebar it appears a rectangle around the typing field..

  • I have exactly the same issue! Even when I am writing this message here I still need to press SHIFT+SPACEBAR to stop one word and go to the next one... So frustrating... Please find a fix, because the writing is almost impossible in so many apps, specially in “google search” in Safari - spacebar makes Enter instead... In addition to this sometimes when you press the spacebarcounter.org it appears a rectangle around the typing field..

Add a Comment