Xcode 11.1 "Unable to Download Xcode"

So I tried installing this update three times. Each time all 7.6 GB "downloads" and begins the "Installing..." shortly after Xcode starts "Installing" I get a notification in the Notification Center "Unable to Download App" "Xcode could not be installed please try again later."
...Anyone else?

Answers

The same thing is happening to me on a 2017 iMac and a 2019 MBP.

same for me ... mbp 2017 / Catalina

Same thing here. Works fine on machines not running Catalina Betas and XCODE Betas so must have something to do with that.

I jsut come here to post about the same thing happening to me.


It was happening last night and I rebooted, tried again; some issue.


Tried this AM from a different network and still not working.

Same here. MacBook Pro 2012. Catalina - not beta, but I had beta versions of it before.

Had a similar issue on both my work iMac and home MacBook. In both cases, I resolved it by removing the existing Xcode 11 before installing Xcode 11.1 from the App Store.

Did you drag it to trash? Did you have to empty trash? I ask because I'd hate to try this and end up without any Xcode at all. So I'd prefer a reversible delete (dragging to trash).

Happens on my MBP 13" 2016 + Catalina as well. Other software (like iMovies) updated correctly after installing Catalina.


+ i'll have to de-activate automatic updates, as after every failed update the App Store appication starts downloading the entire package again...

Yes, I dragged it to the trash. That worked fine on my work iMac but on my home MB, I actually had to purge some of the Xcode files in ~/Library because the App Store thought it was still installed.

Might want to avoid the store and see if you can get lucky via downloads/more Xcode 11.1.xip

Happened three times this morning on MBP 13" 2015 + Catalina (upgraded) as well. Will try to manually delete /Applications/Xcode.app (11.0 from MAS IIRC)

This worked, thank you.


Details, if in case they're relevant to anyone... I trashed Xcode (version 11 was in /Applications). I did not empty the trash. I then went to the App Store app. Xcode did not show up ther under updates, because it didn't see it as installed, so I searched the store for Xcode and installed it fresh.

Yes that worked for me also. Two machines that I had been using for Catalina and Xcode Betas and one that had never seen the Betas.

This also worked for me. Thanks.


Just dragged Xcode to the trash and resintalled from the App Store. No problem.

Can confirmed was able to install Xcode 11.1 (manually).


  1. Drag Xcode.app (11.0) to Trash (and empty Trash)
  2. Directly downloaded Xcode11.1.xip from "Other" downloads on developer.apple.com
  3. Extract Xcode.app by double-clicking downloaded .xip in Finder
  4. Move Xcode.app to /Applications


Don't know if installing from MAS after deleting 11.0 .app would have worked, as did not try that.