Unable to install Xcode 11.1

I Installed Catalina macOS 10.15 however I'm unable to install the new Xcode 11.1 update. The download is successful and launchpad reports "Installing" and then after some time I receve the message "Unable to Download App. "Xcode"could not be installed. Please try again later." When I try again the download is re-started.


Any ideas?


Thnx!

Post not yet marked as solved Up vote post of bahiaprincipe Down vote post of bahiaprincipe
100k views

Answers

Check this thread:

https://forums.developer.apple.com/thread/124010

I had this same problem on several of my machines. Two that I had been using for the Catalina and Xcode Betas and one that had never seen them. My solution was too delete the Xcode app and redownload from the App store. That seems to have worked in both instances. Don't know why.

I tried this but even after moving every trace of Xcode I could find (from /Library and ~/Library) into the trash, I still can't update. The App Store still shows me an Update or Open button but not an Install button.


Rebooting solved it!

What worked for me was to uninstall Xcode first. This proved difficult because macOS reported that some extensions were being used and it wouldn't allow me to delete from the Applications folder. I had a second account on my computer and after logging in to that account I was able to successfully move Xcode to the Trash and empty the trash (emptying is an important step). After Xcode was successfully uninstalled, I rebooted and then re-installed from the App Store. I suspect that the update process was hanging for a similar reason that was preventing me from uninstalling Xcode initially, as to what that detail was exactly is unknown to me. But now I'm set!

I faced the same issue on macOS Catalina.


The following worked for me:

  1. Delete Xcode
  2. Restart computer
  3. Install Xcode from App Store

I would try na different sequence:

  1. Restart computer, and if that's not enough:
  2. Delete Xcode
  3. Restart computer
  4. Install Xcode from App Store

This seems like the most sensible approach. On one of my laptops that has Catalina (never a beta) - I have this same problem. With my other laptop not running Catalina (never a beta).

Downloading Xcode 11.1 from https://developer.apple.com/download/more/ unarchiving and then moving it to the Applications folder solved it for me without having to uninstall the previous version (10.3).

Having the same issues, tried to download through App store 5 times, yet still receive the same message that unable to update.

I ran into the same problem. I had to do all of the following before install from App Store was successful:


In terminal:

1) sudo rm /Applications/Xcode.app

2) sudo rm Library/Developer

3) sudo rm ~/Library/Developer

4) reboot

5) Install Xcode from App store

Thanks, this woked just fine fo me...

Downloaded the Xcode 11.1.xip file from https://developer.apple.com/download/more/ as you suggested, expanded it, and moved the resulting Xcode.app from my Downloads folder directly into the Applications folder replacing the old...

I have exactly the same problem. Tried 5 or 6 times

I will try the suggested download delete option.

I have also discovered that ~/Library/Developer is the main cause of my "other" disk space problem. Is it safe to completely remove it?

Safe to remove Developer completely?

Same for me, but I just went to hard drive, applications folder and deleted Xcode from there, after initial update failed. Xcode 11.1 installed again from app store with no issues after that.

Yes I had two betas of Xcode 11, a stable Xcode10.2, and Catalina 10.15. Would only install up to 76%. Then I deleted the to 11 betas and uploaded fine.