Xcode 11.3 missing Support Files for ios13.3

After installing Xcode 11.3 - I am not able to build for ios13.3 because the highest release of the requisite support files inclused in Xcode 11.3 is ios13.2

Has anyone found a way to obtain 13.3 Support Files?


Thank you for posting this! Your post is the only one I can seem to find on this. I have the same issue.

This is the same question as the other thread: https://forums.developer.apple.com/thread/126948

Same reply: why do you need 13.3 target specifically ? If you set 13.2, it will run on 13.3. as well.

In spite I can run my app from 11.3 xcode in iOS13.3, but device support files for 13.3 is missed in this release of Xcode.

Same here, despite what the Release Notes say.

I think their problem is that their test devices are at iOS 13.3 and they need/want to test their app in a device.

I thought Apple would have solved this issue but I still waiting for the solution, may be in the new xCode version ......

Apple should review these forums to work out the developers issues .... I am afraid not.

same problem here, xcode11.3 seems to be missing ios13.3 device support files

we tried the trick of copying 13.2 support folder and renaming it to13.3, but it didnt work this time

actually it did work when i tried it on a different machine, what i did was make a symbolic link from 13.2 (actual folder) to 13.3

cd /Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/DeviceSupport

ln -s 13.2 13.3

check it:

ls -l 13.3

lrwxr-xr-x 1 user staff 4 Jan 11 13:13 13.3 -> 13.2

restart xcode and retry run on device

You cannot use the GPU Profiler if the iPad iOS does not match the build target.

I resolved by below (Xcode110 Installed):

1. Just made a copy of 13.2 folder

-> `Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/DeviceSupport/13.2`

2. Rename 13.2 folder to 13.3 and copy it to

-> `Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/DeviceSupport/`

3. Restart Xcode

Make a symbolic link from 13.2 device support to 13.3

open the terminal

cd /Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/DeviceSupport

ln -s 13.2 13.3

ls -l 13.3

restart Xcode and retry run on device

Some users might get an issue as

"dyld_shared_cache_extract_dylibs failed"

Follow below steps

go to ~/Library/Developer/Xcode/iOS DeviceSupport/13.2/Symbols/System/Library/Caches/com.apple.dyld

create empty file if it is not there - .processed_dyld_shared_cache_arm64e

restart Xcode and run

It's working for me!!!!

Try and let me know

My iPhone is now up to 13.5 so I tried adapting the advice above thus: ln -s 13.2 13.5 but running my Flutter app on my iPhone didn't work. Has anybody got Mohave Xcode (latest supported xcode on Mojave is 11.3.1) to run on an iPhone device running 13.5.1 ?

Also, am confused about the tip re fixing a potential "dyld_shared_cache_extract_dylibs failed" error - my ~/Library/Developer/Xcode directory does not contain an iOS DeviceSupport directory? It contains:

Code Block
$ pwd
$ ls
DerivedData DeveloperPortal 7.2.db UserData
DeveloperPortal 7.2.1.db DeveloperPortal 7.2.db-shm iOS Device Logs
DeveloperPortal 7.2.1.db-shm DeveloperPortal 7.2.db-wal watchOS DeviceSupport
DeveloperPortal 7.2.1.db-wal GPUToolsAgent.sock

so I cannot create the empty file .processed_dyld_shared_cache_arm64e. Am I supposed to actually create the entire missing path iOS DeviceSupport/13.2/Symbols/System/Library/Caches/com.apple.dyld too?