10.11.4 Kext signing changed?

I am noting that with updating from 10.11.2 or 10.11.3 to 10.11.4 my audio device UAD Apollo TB drivers seem to no longer working as it does not see the device so wondering if anybody knows of kext changes in 10.11.4?

Post not yet marked as solved Up vote post of UA-Bruce Down vote post of UA-Bruce
4.5k views

Answers

I was hoping I could find a fix for my Apollo UAD 2 DUO (firewire) as well. Since updating to 10.11.4, it seems the drivers no longer work.

I experienced similar situation with my USB to Ethernet adapter's driver. Error message indicates invalid signature. The driver works fine on 10.11.3 beta 2.

Me, too. Apollo Twin Thunderbird. Invalid signature in the drivers.

Me, too. For usb SSD driver , SAT Driver using at OS. SAT driver is also invalid of signature.


Please fix it.

Me too.

ATTO iSCSI

ATTOExpressSASRAID2

and

AX88179 USB3.0 to Giga ether

Just upgraded to OS X 10.11.4 beta 2, third-party kext loading still not working. 😟

OS X 10.11.4 Beta 2 still has the same issue with UAD. Since 10.11.4 has so broken so many various devices that were working well in 10.11.3, there is great hope Apple will fix it on their side soon rather than make hardware companys resign and repost updated drivers.

I'm experiencing the same problem with AX88179 USB3.0 to Giga ether

Also having issue's launching Cubase and Nuendo. The eLicenser no longer works with 10.11.4.

It seems that the certificate sign check is broken in 10.11.4 beta (beta 2 as well). Probably all third-party drivers are signed by an "invalid signature" For details:


https://forums.developer.apple.com/message/103541#103541


There is a temporary workaround: disable System integrity protection, the drivers will work then:


https://developer.apple.com/library/mac/documentation/Security/Conceptual/System_Integrity_Protection_Guide/ConfiguringSystemIntegrityProtection/ConfiguringSystemIntegrityProtection.html#//apple_ref/doc/uid/TP40016462-CH5-SW1


My AX88179 driver works correctly now.


Pavol

Great find palkoc!


That got the UAudio drivers to work as well.

Looks like asix has already updated their driver. I haven't tested it, but according to change log, the latest driver should works fine on 10.11.4. Nice work, asix!

http://www.asix.com.tw/products.php?op=pItemdetail&PItemID=131;71;112

For the new drivers for the AX88179 I used these one tonight Asix website it's been update with the new signing to version 2.6.1.

FYI: 10.11.4 Beta Seed 3 UAD issue seems to have resolved the UAD kext signing issue by just updating to Beta Seed 3 from Beta Seed 2. Might also fix issues with other devices with simiar kext signing issues.

Issue does not occur with Developer Beta 3 (build 15E39c).