Uploading archive error: "Missing iOS Distribution signing identity for ..."

I'm trying to upload my iOS app archive to iTunes Connect using Xcode, but when I click "Upload to App Store" I get the error that "Xcode attempted to locate or generate matching signing assets and failed to do so because of the following issues. Missing iOS Distribution signing identity for _____. Xcode can request one for you." I'm really confused, because I had literally just successfully uploaded an archive for the same app about 2 hours earlier, and then I needed to make one simple fix and then needed to reupload the archive, and now I'm getting this error. I literally did not touch anything else. I've done everything that I can think of to try fixing the problem, I restarted Xcode, my computer, went to Xcode preferences to click 'Download All' on the provisioning profiles, clicked "Reset" on the iOS Distribution on the same page, redownloaded the iOS distribution profile from the member center, went to the code signing settings in my app's build settings and manually set the release signing identity to the iOS distribution profile, and rearchived several times. Nothing is working. Help!


Edit: Here's the link about the expiring WWDRCA: https://developer.apple.com/support/certificates/expiration/

This is also confusing, because my app is just a normal iOS app that doesn't fit in any of those categories of people that need to take action. :S

I don't even know how to install the new certificate that they have a download link for. Just get "The System Roots keychain cannot be modified." in Keychain Access...

Accepted Answer

Thanks for bringing this to the attention of the community and apologies for the issues you’ve been having. This issue stems from having a copy of the expired WWDR Intermediate certificate in both your System and Login keychains. To resolve the issue, you should first download and install the new WWDR intermediate certificate (by double-clicking on the file). Next, in the Keychain Access application, select the System keychain. Make sure to select “Show Expired Certificates” in the View menu and then delete the expired version of the Apple Worldwide Developer Relations Certificate Authority Intermediate certificate (expired on February 14, 2016). Your certificates should now appear as valid in Keychain Access and be available to Xcode for submissions to the App Store.

Answers

I've got the same problem.


EDIT - Problem solved : as explained below, deleting the expired (probably hidden) WWDR Certificate (only keeping the new one) solves the issue.

I get the same error, where only yesterday the archiving went through fine. On two different Developer accounts no less. Certs and Profiles are unchanged.


I did notice that my Keychain lists all of my iOS distribution certificates as "This certificate has an invalid issuer". Opening one certificate and looking at the certification chain, I see that an intermediate certificate has expired! It's the Apple Worldwide Developer Relations Certificate, and it expired just before 20:00 CET (1.5 hours ago). Looks like a smoking gun to me...


Not sure how to resolve this, though.


Also, we seriously need more specific and better error messages for certificate issues.

I had the same issue -- uploaded a good archive a few hours ago, then did another and it says no valid signing identities.

Then you look in Preferences and double click on your name in Xcode and it lists all the certificates as "Revoked".

However, go into Keychain Access, under Login keychain and find iPhone Developer and iPhone Distribution. In mine case, both say "invalid issuer".


I thought this must be related to the WWDR certificate expiring today (even though the article https://developer.apple.com/support/certificates/expiration/ says it shouldn't matter).


Updated WWDR and even tried issuing new certificates, but even though new ones show invalid issuer.


Here's a reddit link to the same topic:

https://www.reddit.com/r/iOSProgramming/comments/45siza/this_certificate_has_an_invalid_issuer/


Obviously urgent,
Thanks all!



** EDIT **

Looks like the solution was to delete the old certificate (check the reddit link above). Go to Keychain Access. Under the View menu, click Show Expired Certificates. Then find the WorldWide Developer Relations ones in login and System keychains and delete. Be sure the WWDR cert is set to "Use System Defaults" instead of "Always Trust". After that everything seemed to work.

Same problem here.

• "This certificate has an invalid issuer" on Developer and Distribution certs..

• Installed the new Apple Worldwide Developer Relations Certificate, and generated new certificates. Didn't help

• XCode reports Developer and Distribution signing identities show as Revoked.

Same problem here - built fine yesterday.


Anyone know how to fix?

Update: I deleted the iOS Distribution certificate from my keychain, and clicked the "Reset" button in XCode, after while the keychain shows 2 such certificates, with an expiration date indicating that it's a freshly generated cert. However it is still using the expired intermediate certificate from Apple.

Same here. WT...?

I have the smae problem. My build was successhul but I am not able to upload the archives to itune connect. Its giveving the same error "Missing iOS Dirstribution sigining identity for..."

As mentioned my Intveltr , all my certifictaes have become invalid and I do see that "Apple WorldWide Developer Relations Certification Authority" have just expired two hours ago Feb 14, 2016 at 1:56:35 PM.

I downloaded the certificate again from the developer account but it has the smae issue. Not sure but we may have to re-generate the certificate and see it gets valid intermediate cert.

/Mishi

Same issue...

Ok guys, we all know that we have issue with this. Instead of posting replies like : same here etc, wait for someone with proper solution for this issue. Just follow the thread and hope that someone will come up with step by step solution


Until then...

Same here

Same goes for me

same here

Apple have notified about the this certificate expiration and the new certificate as well. But they didn't specify about this perticular issue and what needs to be done. Please see below links.

https://developer.apple.com/support/certificates/expiration/

https://developer.apple.com/certificationauthority/AppleWWDRCA.cer

Yeup. Spent 4 hours trying to fix it, didn't realize it was an ongoing phenomena.