Home app stuck on Loading Home... screen

When I launch the app it just gets stuck on this white screen that says Loading Home. I tried deleting it and reinstalling from the App Store but no luck so far. I see my devices and scenes in the Control Center widget. Anyone else having issues?

Post not yet marked as solved Up vote post of onefoot17 Down vote post of onefoot17
203k views

Answers

I had the same problem but then discovered I didn't have iCloud Keychain enabled. Once I enabled it and rebooted the device, that problem went away.

Didn't work for me, any other potential fixes, I'm currently on an SE

Remove home app, hard reboot (home button + power button) , reinstall app. Enter settings - open home app configuration- enable iCloud and reset all settings That worked for me

This didn't work for me either. I only have this problem when I'm signed in to a specific Apple ID, and I cannot figure out what's going on- no HomeKit apps are working with this Apple ID.

Post not yet marked as solved Up vote reply of scj Down vote reply of scj

I have Home working on my iPhone but my iPad Pro displays Loading Home and stays there. Anyone know how to rectify this?

I had the same issue. It worked on my iPhone 6, but received "Loading Home" on iPad Air2. On the iPad I did a "Erase All Content and Settings" and then it worked. Not the best work around, but it worked.

I ran to the same issue. Resetting the iCloud Keychain associated with the AppleID they is being used on the iOS 10 device fixes the issue.

Do you mean the reset described at the bottom of this page? https://support.apple.com/en-us/HT202755

Correct.

Was having the same issue with an iPad Air 2 - none of the above steps helped, but Beta 2 seems to have resolved the issue.

I'm still having this issue on beta 2. It only happens with one Apple ID.

I am also having the same issue. Everything was working fine in ios9. Now I always get "iCloud Data Sync in Progress" or "Loading Home" in ios10 Home app. Even after I restore my iPhone to a new iPhone. Once I log into my account, it will always stuck at Loading Home. Any help would be greatly apprciated.

I'm having this same issue. No matter what I do, all of the options on this thread have not helped. Has anyone had any luck? Mine still says "Loading Accessories and Scenes". I'm on Beta 5 now.

I got a similliar problem, but in my case it is an invitation as guest to a home. I accept the invitation in Beta 5, the home is added twice and both have the Spinner not stopping.


Already reset iCloud access on the beta device, but this does not help. Send a Feedback to Apple.

Any thoughts on this? We're nearing the GM and I'm still having problems. I definitely think it's related to my Apple ID / iCloud / Keychain because I'm able to use the Home app if I turn iCloud off completely.