Purgeable Space Problems

I recently installed the MacOS Sierra beta and have recently noticed that whenever I free up space on my mac, Disk Utility adds the freed space to the purgeable portion rather than the free portion. This has become quite an issue as I now need to partition my drive but disk utility currently shows 146 gb as purgeable and only 36 gb as free. It however claims that 182 gb is available. Is there anyway I can convert this purgeable space to free space?

Accepted Answer

I think I somewhat managed to solve this by creating a smaller partition and then deleting it. I am now able to use the entire purgable space for partitioning.

Answers

I think I somewhat managed to solve this by creating a smaller partition and then deleting it. I am now able to use the entire purgable space for partitioning.

I don't think currently there is a way to purge this space manually as of yet. (I asked something similar in https://forums.developer.apple.com/thread/50073 )

As a work around for this I did the following to force the space to be cleared.


In the terminal I used the mkfile command to create a file large enought to completely consume the remaining free space on my drive.


"mkfile -n 60g ~/Desktop/BIGFILE"


Replace 60g with whatever file size you would like.


Once that command was finished I rebooted. I am not sure if this next step is necessary, but I didn't want deleting theses files to just create more purgable space so I used RM in the terminal.


"sudo RM ~/Desktop/BIGFile"


By doing this I was able to clear enough space for what I was wanting to do. I have also not noticed any unwanted side affects of this process and I have now done this multiple times for various reasons.

It doesnt work for me, any other solutions found?

I finally solved this issue on my macbook air after doing much research online. The descrepancy in my case between the available space reported in finder and the available space in about my mac was due to local snapshots created through the time machine utlity. Although these were seen by about my mac as purgeable, finder was not able to see them in the same way, it seems


open terminal and run the command 'df - h'

if you see a volume called mobilesync, with a load of used space, thats the culprit.

run command 'sudo tmutil disablesync' and enter your password when asked

run 'df -h' again and the mobilesync volume should have dissapeared, and your space on your startup disk should be reporting the recovered space

run 'sudo tmutil enablesync' to get backup back online and you should be good to go

about my mac->storage will have a bit of a funny turn while it sorts itself but will report correclty again in a few minutes - dont panic.


Please note, this worked for me, it may not solve your issue

Running any terminal commands with elevated permissions (sudo) carries some risk - only follow these instructions if you are comfortable with this.


Nick.


PS let me know if this solves your issues, it would be good to spread the word if this is not just a fix for me.

Are you talking about Mobilesync in Application Support? That is the Backup for your iOS device, mine is around 17gb big. I would not delete that though, even if it gives me space.

I simply opened Time Machine Preferences, clicked the Lock Icon to unlock and make changes. Then I unchecked the box next to Back Up Automatically under the TM Icon. Finally I restarted my Mac. When I turned my Mac back on to check the storage all the purgeable data was gone which freed up over 70 GB on my SSD. Afterwards I went back into the TM preferences and rechecked the Back Up Automatically box. After restarting my computer a second time I saw that the purgeable data was still gone.

It works for me, thanks.🙂

Thanks! This helped me. Much simpler solution than others offered here.

Simple, yet genius! Thanks!

Oh wow this worked for me. Thanks so much. Have spent hours on the telephone with Apple over this. The tech support guys don't know this.

A simple way to reclaim the "Purgeable" disk space is to secure erase the disk with the commandline diskutil:


diskutil secureErase freespace 0 /dev/disk1


Will do so for the startup disk

Post not yet marked as solved Up vote reply of gert Down vote reply of gert

This worked first time for me! Thank you!

Perfect solution. Thank You

Thank you! Such a simple solution!