Unable to Activate Auto-Unlock

Hello,


So i've installed the beta 2 on all of my devices, enabled 2 step factor auth etc... etc... Everything seems to be working but when i hit the checkbox to enable the service, i get stuck with a endless 'Turning On...' spiral and it never ends. If i close everything and come back, rehit the 'Allow your Apple Watch to unlock your Mac', i get the turning On... again forever.


Any ideas on how to fix this?


Thanks,


Phil

Post not yet marked as solved Up vote post of ZikPhil Down vote post of ZikPhil
65k views
  • I have the same issue. Did all the recommended things of rebooting everything , turning off sharing and so on. Still get the spinning wheel. Apparently its waiting to the watch to display allow $%^s MacBook Pro to access and push the side button on the watch twice to accept but that stage never happens. It seems the laptop doesn't see the watch. and is waiting for a response that is not going to happen. Im on a MacBook Pro 2021 14". My other Macs are working with the watch just fine.

Add a Comment

Answers

Just thinking, because I can not test it now.


iPhone 6s iOS10 beta 2

AppleWatch watchOS3 beta 2

MBP Late 13 MacOS sierra beta 2


I saw the option for a while after installing on the MBP. Got the spinning wheel, but no functionality, it never went away. Then I "logged out of" iCloud, after that I do not even see the button anymore. 2FV and all that is active, I see all the devices in iCloud...


Could it be they have to be in the same WLAN for this to work? Or at least for the setup to work? I can not really test that at work because the WLAN is proxied and all that.... so no idea. How does this work anyway? Bluetooth alone can't be, that is not close enough to work reliably. Must be something else....


s.

Nope, not working either. Just tried it (usually I'm on LAN at home, but tested it on WLAN. Unfortunately getting same result. Honestly I am thinking about doing a clean install, but it's so much trouble for just one feature. Especially if it is just some kind of weird bug...

Working on my Macbook 2015. Just turned on two factor authentication, rebooted watch and macbook and the function started working.

I was successful in activating it on my Macbook Pro Retina, but my late 2015 iMac 5K it activates but will not login and reverts to the standard password entry. Not sure what the issue is there. It breifly mentions something about pairing but goes away.

Did that of course. Two factor authentication is on and actually works. Rebooted all of the devices (MacBook, Apple Watch and even iPhone). Getting same result constantly. Strange thing is that I'm getting this message on my Mac, asking to enter a passcode that should be showing up on my Watch. But that does not happen at all.


See url for image:

http://forums.macrumors.com/attachments/schermafbeelding-2016-07-06-om-15-29-44-png.639190/

Text in window is in Dutch, but it just says:

"Link request from: Apple Watch of Tom


Enter passcode that is displayed on the external Bluetooth device."

Same problem for me with my iMac Late 2013, after updating i see the checkbox and after update my 2 factors security, the box disapear and nothing. I tried ti reboot iPhone, iMac, Watch and disconnect- connect iCloud but nothing. I tried also reinstall the OS and same problem. I think i can wait a version 3 to use this feature 🙂

for me it's working. Installed beta 2 on all my systems and enabled two-factor as also disabled two-way auth...

BUT for me it's only working if i'm not connected to my external (thunderbolt) display... -.-


if i have my thunderbolt display connected, it seems like trying to unlock with the watch but then i still need to enter my password... 😟


anyone with the same problem or solution to this?



thanks much and best regards,

Chris

Had the same issue on my 2016 rMB. I logged out of iCloud on my computer and then logged back in. Got it to finally set up. Haven't tried to see if it works though yet.

Hey, thank you!! This actually worked for me. 😀

same thing with late 2013 mac pro. saya turning on forecer. it works with my mac book.

Worked for me too! Awesome!

I had this feature working right after installing the latest beta on my Retina MB, late 2013. It was fast and working great. I followed the instructions in the release notes for OSX Sierra current beta to get it up and running. I tried the auto unlock feature at least a dozen times over the day and it worked just fine. This morning when I got near my MB, my Apple Watch started pinging me saying it was unlocking my MB even though I hadn't opened the lid. Then when I did open the lid, auto unlock failed to work. It tried (spinning circle, says "unlocking...") then the message and spinning circle disappeared as it reverted back to asking for my password. Password unlocked the MB. System prefs on the MB shows a check mark next to the auto unlock feature in the General tab. iPhone watch app shows my apple ID, and I'm using the 2FA per instructions. It simply refuses to work now. Rebooting the MB and watch had no effect, nor has logging on and off iCloud on the MB. Something changed, just not sure what. If I come up with a workaround, I'll post it.

Glad to have been of service!

Having said that, I haven't manged to get the auto unlock feature to actually work though....

Make sure that you use the same Apple iD for iCloud et the App/iTunes Store. Avoid a me.com for icloud services and another one for iTunes store.