Unable to Activate Auto-Unlock

Hello,


So i've installed the beta 2 on all of my devices, enabled 2 step factor auth etc... etc... Everything seems to be working but when i hit the checkbox to enable the service, i get stuck with a endless 'Turning On...' spiral and it never ends. If i close everything and come back, rehit the 'Allow your Apple Watch to unlock your Mac', i get the turning On... again forever.


Any ideas on how to fix this?


Thanks,


Phil

Post not yet marked as solved Up vote post of ZikPhil Down vote post of ZikPhil
65k views
  • I have the same issue. Did all the recommended things of rebooting everything , turning off sharing and so on. Still get the spinning wheel. Apparently its waiting to the watch to display allow $%^s MacBook Pro to access and push the side button on the watch twice to accept but that stage never happens. It seems the laptop doesn't see the watch. and is waiting for a response that is not going to happen. Im on a MacBook Pro 2021 14". My other Macs are working with the watch just fine.

Add a Comment

Answers

I get 'Turning On...' spinning for a while and then the error 'Your Mac was unable to communicate with your Apple Watch.' Have tried multiple restarts of everything, as well as turning 2FA off and on.

  • The same still applies in 2021. Apple Watch OS - latest release, same with iPhone and MacBook running Big Sur. Same WiFi, bluetooth on, passwords, 2FA in place and no go. This feature is damn good and I would expect it to work before end of the world. If there is a fix - I would really appreciate.

  • I too did all the suggestions and the same bad results. . . while I was here on this page, and watching the spinning pinwheel, which had already been spinning for almost 10 minutes. . . and with nothing further on my part, it connected and is now working. Except for the exceptionally long wait, I did all the already mentioned suggestions. So maybe wait longer? Sorry I don't have anything definitive.

Add a Comment

same

I have succesful aktivated Auto Unlock, but unlock doesent work. The Apple Watch is on my wrist, unlocked and directly in front of my iMac. Turn the auto unlock option off and on, reboot mac, reboot watch doesent help.

With 2FA enabled and Beta 2 on my mac and Apple Watch When I go to turn on Auto Unlock it just says Turning on... with the endless spinning wheel have tried restarting and nothing has been working so far. Anyone else have any luck?

I am having the exact same experience.


Apple ID has 2FA not 2FV as required. Watch OS beta 2, Sierra Beta 2, iOS 10 beta 2.


Spinning wheel to the left, "Unlocking with Apple Watch" shows for a bit then I get a password prompt with no errors. Password works fine.


The irony that it now takes longer to log in if the auto unlock is activated is not lost on this developer.

Where is the setting? I can't seem to make it show up on my iMac. Is there some order I need to log into devices in?

Chances are, like me, your Mac is earlier than 2013? According to the release notes (page 3) only 2013 and later Macs can use this feature. http://adcdownload.apple.com/Documentation/macOS_10.12_beta_2_Release_Notes/macOS_10.12_beta_Release_Notes.pdf

It's a late 2013 iMac and has supported handoff and continuity functionality before.

same issue here and I have a 2014 MacBook Pro... dont even have the option to enable it on my mac.

Early 2013 macbook Pro no option to enable it on my mac.....


2FA enabled, all devices on beta 2s...

tried everything from signing in and out icloud to repairing apple watch to iphone


nothing.

It kept spinning for me and then asking for the password on my 2016 macbook until i closed the lid, then reopened it and now it works fine... I wonder if the the initial set up needs the clamshell to make the sync for the auto unlock to work.


I have now gotten it to work with both opening the clamshell as well as just going Apple Menu > Sleep (note that I have set the initial requirement for requiring the password to immediate from 5 minutes... if this is relaiable I am going to keep this setting and praise the Apple Gods because this is way more secure and convenient).

On my late 2014 IMac 5k 2FA is enabled on iPhone b2 and Mac b2 in the settings the feature will not show in the pane. I have tried logging out of iCloud and back in restarting device etc.

So! Apparently logging off of iCloud on your mac and re-adding it seems to do the trick, you might have to reboot after to get rid of the 'Unable to connect to Apple Watch'. Everything works fine for me in the admin BUT the functionnality itself is not working. Waiting for Beta 3...

Same here. MacBook Pro Retina 15" Early 2013 and can't see the option....though the relase notes say it should work (The Auto Unlock feature is supported on 2013 and newer Macs). Filed a bug report and waiting for a reply. Cheers,

That would be strange, as 9to5Mac got it working, they made a video about it.


So there's gotta be a fix for this. I've tried so many things. Rebooting my iPhone, Apple Watch and Mac didn't solve the issue. Switching off and on the functionality on my Mac didn't fix it either. Last thing I tried was turning it off, rebooting my Mac and then turn it on again.


The thing is, it asks for some kind of pairing code (like you usually would need to pair a Bluetooth device). But I don't think that should happen, does it? Anyway, that message to fill in a pair code goes away after 10 seconds or so, like it automatically paired. Just curious what causes the issue not being able to unlock my Mac. It results in exactly the same as what you've got: it 'searches' but then prompts me with a password input box anyway..