Installing macOS Big Sur beta

I installed the profile for macOS Big Sur, but I got updated to Catalina beta 10.15.6 beta instead.

Is it possible to install the Big Sur beta already?
Up vote post of atineoSE Down vote post of atineoSE
Post marked as solved 1.0.0k views

58 Replies

Here’s the list of macOS Big Sur compatible Macs:

2015 and later MacBook
2013 and later MacBook Air
2013 and later MacBook Pro
2014 and later Mac mini
2014 and later iMac
2017 and later iMac Pro
2013 and later Mac Pro
Hello,

I have installed MacOS BigSur public beta. But today I got MacOS Catalina 10.15.6 as an update.. I have accidentally hit update on the notification bar and realized it is supposed to be BigSur 11 instead of Catalina 10.15.6.

the system restarted and I saw an Apple logo with the loading bar. After that I’m stuck at blank screen forever. After 2 hours I lost my patience and did a force restart. I’m still getting blank screen at startup. I have tried resetting the NVRAM, SMC, tried to boot in safe mode also in recovery mode. But nothing works I’m still seeing blank screen.

I talked with Apple customer care and they are suggesting booking an appointment and they might clean install the OS but I don’t want to lose my data. I don’t have the backup.

can anyone help me to recover the data or fix the boot issue?

Thanks in advance
I was on a startup drive with a copy of Catalina. I think Apple may have made it difficult to put a beta on a boot drive. I only had luck by getting another fast non-spinning drive. I had no problem installing on a drive I just formatted. Apple really needs to have a simple way of explaining apfs in its various flavors. You then have to decide.

One thing I'm dimly understanding about apfs is that it puts your data wherever there is room. Including volumes on other hard drives or flash or ssd. There's no app yet that gives you a useful idea of what drive has what on it. apfs does some great things, but they need to communicate with the average Mac user. I would love to see some documentation, like the privacy paper and so on. I have made mistakes handling it. Suddenly I see only my data volumes. With that, Big Sur is still beta until all the OSes are finished. As apfs seems still to be.

Anybody know what I can read from Apple or anyone else?
okay
𝙔𝙚𝙨... 𝙏𝙝𝙚 𝘽𝙄𝙂 𝙊𝙉𝙀!



𝐎𝐛𝐯𝐢𝐨𝐮𝐬𝐥𝐲 𝐁𝐞𝐭𝐚 𝐰𝐢𝐥𝐥 𝐛𝐞 𝐫𝐞𝐥𝐞𝐚𝐬𝐞𝐝 𝐟𝐢𝐫𝐬𝐭. 𝐈'𝐦 𝐠𝐨𝐢𝐧𝐠 𝐭𝐨 𝐜𝐡𝐞𝐜𝐤 𝐰𝐢𝐭𝐡 𝐭𝐡𝐞 𝐥𝐚𝐮𝐧𝐜𝐡 𝐛𝐮𝐭 𝐈 𝐛𝐞𝐥𝐢𝐞𝐯𝐞 𝐲𝐨𝐮 𝐰𝐞𝐫𝐞 𝐫𝐞𝐝𝐢𝐫𝐞𝐜𝐭𝐞𝐝 𝐭𝐨 𝐭𝐡𝐞 𝐥𝐚𝐭𝐞𝐬𝐭 𝐂𝐚𝐭𝐚𝐥𝐢𝐧𝐚 𝐮𝐩𝐝𝐚𝐭𝐞 𝐛𝐞𝐜𝐚𝐮𝐬𝐞 𝐁𝐢𝐠 𝐒𝐮𝐫 𝐢𝐬 𝐧𝐨𝐭 𝐚𝐯𝐚𝐢𝐥𝐚𝐛𝐥𝐞 🅹🆄🆂🆃 🆈🅴🆃.

I believe the original projection on the launch for Big Sur was November, possibly September...
































































































































































































































































































































































































The public beta (what is more appropriate for the original poster & other non-developers) of macOS Big Sur is now officially available: https://beta.apple.com/sp/betaprogram/guide#macos

Anything before this was not recommended for non-developers, people that need their computer & data to work reliably, etc. Even then, this public beta is still a beta. Things will still not be working entirely correctly (including third-party software that hasn't updated to support the new version yet [since it's not officially released yet]) even with this being a publicly-available beta (key word still being beta.)

If you need things to continue to work smoothly, the official release isn't too far away & you should probably wait. Keep in mind that even official releases can have some bugs (many potentially having to do with third-party software, at that point) so getting it earlier & earlier before then just leaves you open for more & more problems (definitely shouldn't step outside of what upgrade profile you officially have like many have suggested here since you then can't get proper support if/when things happen.) Of course, I wouldn't hold off on an official release (when that happens in the next couple months), though, unless there's a known compatibility issue with something you need.
I have similar issue for my 2016 13" MacBook Pro. I installed the Big Sur Developer version, the update won't showing up. I tried those popular methods from internet, but they don't work for me. The software update windows showed "Your Mac is up to date - Mac OS Big Sur Beta 11.0" How come.....
Steffen_Volgmann's answer works well, thank you. Just be patient after you run it, when you open Software Update, it takes a minute to load in the BigSur update.
Keep in mind that the solution by Steffen_Volgmann does put you on the developer beta path instead of the public beta path. As such, these are betas not seen to be fit for the public beta program yet (let alone to be used for reliable general use that comes with the official full release) & are more likely to have bugs & other issues of varying seriousness (some potentially being quite serious [possibly even totally messing up your synced data, needing a full re-install/restore from backup, etc.])

Apple doesn't have the public beta of Big Sur currently available on purpose so keep that in mind when deciding whether or not to move forward with the developer beta profile. I'd recommend waiting for the full release this fall if you're planning on general use, but certainly wait for the public beta if you're not a developer that absolutely needs it & is prepared to deal with the issues it has (potentially then not being able to get sufficient support due to running the developer beta without an active developer plan.)
Steffen_Volgmanns solution worked for me, and I am NOT a paying Apple Developer.
Thanks Steffen_Volgmann! That worked.
Just got it... Commands listed by Steffen_Volgmann worked perfect. Thanks Steffen!

My Mac... MacBook Air (13-inch, 2017)

open terminal
sudo -i
enter root password
/System/Library/PrivateFrameworks/Seeding.framework/Versions/A/Resources/seedutil

Unenroll from the Beta Program 
/System/Library/PrivateFrameworks/Seeding.framework/Versions/A/Resources/seedutil unenroll

Enroll in the DeveloperSeed Beta 
/System/Library/PrivateFrameworks/Seeding.framework/Versions/A/Resources/seedutil enroll DeveloperSeed

Close and re-open System Preferences > Software Update
The new Beta should now show up
I had the same issue. The following from another user worked for me. I took like a minute for it to update before I could download.

I had the same problem that after installing the public beta profile for Big Sur, I was only offered an upgrade to the latest beta from Catalina. 
So I ran sudo as root via terminal and typed the commands there:

open terminal
sudo -i
enter root password
/System/Library/PrivateFrameworks/Seeding.framework/Versions/A/Resources/seedutil

Unenroll from the Beta Program 
/System/Library/PrivateFrameworks/Seeding.framework/Versions/A/Resources/seedutil unenroll

Enroll in the DeveloperSeed Beta 
/System/Library/PrivateFrameworks/Seeding.framework/Versions/A/Resources/seedutil enroll DeveloperSeed

Close and re-open System Preferences > Software Update
The new Beta should now show up
I want the new BIG SUR BETA
Steffen's solution worked for me as well. Thanks much.

To recap, in Terminal enter
Code Block
sudo /System/Library/PrivateFrameworks/Seeding.framework/Versions/A/Resources/seedutil unenroll
sudo /System/Library/PrivateFrameworks/Seeding.framework/Versions/A/Resources/seedutil enroll DeveloperSeed

Then, in System Preferences, open Software Update and wait a few seconds. "macOS Big Sur Beta" shows up.