Parallels 15 (Mac): Updating macOS Catalina Beta to Big Sur Beta

When I select the main disk to install to, I get the error message: "The operation couldn't be completed. (BIErrorDomain error 3.)"

Has anyone else experienced this? I wanted to try out the Big Sur beta, but didn't want to risk rendering my daily MBP unusable.

Thanks!


49 Replies

@paulr9773, I installed from a DMG. Once you have the Big Sur installer, you can create a DMG as follows:

Code Block
cd ~/Downloads/
sudo hdiutil create -o InstallMedia -size 20G -layout SPUD -fs HFS+J -type SPARSE
sudo hdiutil attach InstallMedia.sparseimage -noverify -mountpoint /Volumes/install_build
sudo /path/to/install.app/Contents/Resources/createinstallmedia --volume /Volumes/install_build
# The next step might fail. If so, manually eject using finder.
sudo hdiutil detach /Volumes/Install\ macOS\ */
sudo hdiutil convert InstallMedia.sparseimage -format UDZO -o InstallMedia.dmg
sudo rm InstallMedia.sparseimage


In VMWare, create a new VM and customise, setting the hard drive to at least 60GB. Boot from the install DMG and run disk utility. Select the hard drive and erase as AFPS, then the drive should go from 40GB capacity to 60GB. Then quit disk utility and install.
I was able to get past the "BIErrorDomain error 3" issue in Parallels as follows:
  1. On a real, supported Mac, run this command in Terminal:

Code Block
ioreg -l | grep board-id

2. Make a note of the board ID (mine is Mac-551B86E5744E2388, for example)
3. Run this command in Terminal:
Code Block
sysctl hw.model

4. Make a note of the hardware model (mine is MacBookPro14,3)
5. In the VM configuration, under Hardware -> Boot Order -> Advanced Settings -> Boot flags, enter the following (inserting the information noted above where shown):
Code Block
devices.mac_hw_model="<model>"
devices.smbios.board_id="<board ID>"


That should be enough to allow the installer to proceed.
Using the steps above, I'm able to install a fresh copy of Big Sur using Parallels 15. However I'm not able to login with the user that I created. I get the same login issue if I upgrade a vm from Catalina as well. I enter my password, login, the system spins for a little while, the screen goes black and then it is back to the login prompt. If I enter a bad password it tells me. This only happens with a good password. Is anyone else able to get past the login prompt?
I am seeing the same thing. I tried to see if its a Parallels related issue by trying it natively, and it seems to work as expected outside of virtualization.
I created a bootable DMG to attempt to install from scratch, but the same problem occurs. I also tried erasing the disk and formatting as APFS, but still the same error. It seems it is an issue with Big Sur installer/parallels.
I am unable to upgrade from 10.15.6 Beta (10G46c), I am receiving the following error:
The operation couldn't be completed. (BIErrorDomain error 3.)
I have tried installing on the same HD as the Catalina Beta and also tried adding a new HD but the same issue...
I'm using Parallels Desktop 15 Pro Edition
Version 15.1.4 (47270)
I tried adding another disk and that failed as well, guess we need Parallels to sort this out.
I had the "(BIErrorDomain error 3.)" and I could fix it using @danfry solution.
Now, I'm stuck at he login screen, just as @Samus22.
  • I upgraded from a Catalina VM.

  • Added the model and board boot options.

  • I needed to remove Parallels tools.

  • Increased the HD from the 64gb default to 128 gb.


I just finished updating my article with the latest info. Please let me know if I have left anything out.

https://mrmacintosh.com/how-to-install-macos-big-sur-beta-on-vmware-fusion-parallels-desktop/
It works in VMWare Fusion! You need to expand the default drive size of 40GB to 60GB and then use disk utility to erase it (as AFPS), then install as normal.
Ok, based on the replies, it looks like an issue with Parallels 15 and Big Sur...guess I'll try contacting parallels. Will report back here if anything useful is learned...thanks everyone.
Running into the same issue on VMWare Fusion and ESXi. I'm attempting to install from an OSX1015 image.

nrbrook, did you install from an OSX1015 image? Did you install from a new partition?
I’m watching this one too.
Same issue here. I'll give VMWare and see what happens.
Same issue here, hopefully someone will figure this out soon!