Docker won't run on Big Sur

Docker won't start on Big Sur. Has anyone else tried it? I'll re-install to see if that helps, but Docker doesn't start right after updating.
Post not yet marked as solved Up vote post of kurtinatlanta Down vote post of kurtinatlanta
5.7k views

Answers

Haven't updated yet but did you happen to have a look at the logs?
Docker 2.3.0.3 starts and is running on an iMac with Big Sur installed.
I was running the edge (beta) version of Docker. Reverting to the release version resolved my issue. Docker is up and running on Big Sur.
I have the same problem. I tried docker & docker edge versions on Big Sur 20A5395g.
For me helped next:
Go to Docker Troubleshoot -> Clean/purge data -> Reset to Factory defaults.
I had this problem initially when first getting onto the Public Beta for Big Sur. The issue turned out to be something to do with VirtualBox. As I wasn't using VirtualBox for anything at the time I uninstalled VirtualBox and Docker has been working again up until a few days ago when I re-installed the latest release of VirtualBox which (apparently) now has support for Big Sur. Now Docker simply will not start again.

Clearly there must still be some issues with running the two together still on Big Sur.

I've just uninstalled VirtualBox again and Docker starts up fine.
I had the same problem on Big Sur 11.0.1 Beta where I had both Docker App 2.5.0.0 and Virtualbox 6.1.16 installed. I had to remove/uninstall Virtualbox to get the Docker App to run. I tried several versions of Virtualbox, but to no avail. Both VB 6.1.16 and Docker 2.5.0.0 run well on Big Sur 11.0.1 Beta but only when one is installed without the other. In other words, VB can only run when Docker is uninstalled, and vice versa.

Does anyone has an explanation for this and/or a suggestion to get them to work side by side?
Hi, this is a breaking change that can be fixed by upgrading your docker version to 2.3.0.4 Docker already pushed an update and upgrading docker fixes the bug of it not lunching on your Apple Big Sur.
Docker 2.5.0.1 is supposed to fix that issue and has been released three days ago.
Docker Desktop is not working on my macOS Big Sur.
Unable to fetch Backend API error is shown.
I found this video helpful to run Docker on  macOS Big Sur on YouTube titled "Docker on macOS Big Sur
"

turn off firewall then allow all connections. Add docker to connections list and run docker it will work.