Problems with WiFi on macOS Big Sur

I've updated to Big Sur from Catalina and I'm having trouble when connecting to WiFi networks. At first no network appeared and now even though it has connected silently to my usual network, it is showing as no connected, but internet actually works.

Anyone having this kind of problems so far? I haven't seen anything related on the forums nor the release notes.

Solved Answer

Could you please report this via https://feedbackassistant.apple.com and attach a sysdiagnose?
You can trigger a sysdiagnose by running sudo sysdiagnose from Terminal. Thank you!

116 Replies

Could you please report this via https://feedbackassistant.apple.com and attach a sysdiagnose?
You can trigger a sysdiagnose by running sudo sysdiagnose from Terminal. Thank you!
I did, but was curious if someone else was getting the same behaviour.

Thanks for your reply!
I do. I can’t connect through WiFi with anything.
No wi-fi and no connection

I tried reinstalling system from recovery and everything seems normal now. Maybe that helps.
I am having the same issue on my iMac (Retina 5K, 27-inch, Late 2015). Wi-Fi icon in the menu bar has a line through the Wi-Fi icon. When I click on the Wi-Fi icon from the menu bar, it first beachballs, then the drop down appears, and then I can attempt to turn Wi-Fi on. However, it will not turn on.

Going into System Preferences > Network > Wi-Fi, at first the settings under Status: says "<
Yesterday I had only 1 W-Fi bar, running Big Sur on new MBP 16in. I restarted computer and it was fine. To be fair, initially the MBP was connected to my main gateway which is a number of thick walls away, and not connected to the extender pod in that room. When I restarted the MBP it connected to the pod with full bars. I installed Big Sur on my iMac 2018 27in today and have full Wi-Fi bars.
Same problem here
entered recovery mode, re-installed X-Code 12 and Big Sur
now Wi-Fi is working even faster than before but no Wi-Fi icon

Has anyone found any solution to this without reinstalling the OS? Maybe there is a preferences file to be cleared that can fix this?
If anyone else has this issue, if you follow the steps on this post apple.stackexchange.com/questions/284581/wipe-all-wifi-settings-from-macbook will restore wifi.
@Developer Tools Engineer - I am still having dropout issues on the second beta. I sent feedback in regards to the first beta, should I just update that ticket or close it off and start a new one?
Having the same issues connecting to my wifi after upgrading to Big Sur as part of the Developer's Beta. I'm trying to report this incident through the Apple feedback system but the Internet keeps on disconnecting. Help!
I also had this issue today after installing beta 2. I followed the in instructions at the link below (thanks @axolotl) and it resolved itself perfectly, so far!
earlier today i upgraded to macOS Big Sur public Beta 2 - and since then the Mac won’t connect to the internet....

i tried everything in this thread- but with no luck.

Anyone else seeing this?
And know how to solve it?
Issue still exists in Beta 4. Connects for approximately 2 minutes, then drops, even though shows connected to my network. Anyone have any solves? Right now, Beta 4 is unusable.