Problems with WiFi on macOS Big Sur

I've updated to Big Sur from Catalina and I'm having trouble when connecting to WiFi networks. At first no network appeared and now even though it has connected silently to my usual network, it is showing as no connected, but internet actually works.

Anyone having this kind of problems so far? I haven't seen anything related on the forums nor the release notes.

61 Replies

Could you please report this via https://feedbackassistant.apple.com and attach a sysdiagnose?
You can trigger a sysdiagnose by running sudo sysdiagnose from Terminal. Thank you!
Ok so I had the same problem my WiFi was connected but not working as I checked on the network page in system preferences, I also tried to plug in a either net cable directly and exactly the same issue it was showing as connected but not getting internet.

i tried all the suggestions here in the chat but no luck, I then realised that I saw somewhere that you need to disconnect your VPN and just before this issue happened I was trying to use my VPN but did not make the connection at the time.

not sure if there is a bug in Big Sur that has issues with VPNs but it seems this was the issue, my VPN was constantly trying to connect with no luck but as it’s truly oh to connect it’s on a constant loop so this was blocking the internet while looping.

so I went to System Preferences > then in the list I clicked on VPN and I could see it was trying to constantly connect so I could not disconnect it from there.

so I opened up Finder and click on the applications folder and deleted my VPN application there, as soon as I did this the internet stringed to life and it’s all working ok.

hope this works for others as it’s super worrying when this issue occurs, it must be some sort of bug in big sur or something
I recently updated to macOS Big Sur 11.0.1 and I faced the same challenge. The network data transfer rate dropped over Wifi. These are the following steps advised by Apple Support:

A. Reconfigure the DNS
steps:
  1. System Preferences

  2. Network

  3. WiFi

  4. Advanced

  5. DNS tab

  6. Add 8.8.8.8 or 8.8.4.4

  7. Click OK then Apply

B. Adjust Packet Size
steps:
  1. System Preferences

  2. WiFi

  3. Advanced

  4. Hardware tab

  5. Configure location from automatic to manually

  6. MTU 1453

  7. Save/Apply

C. Change location and renew DHCP lease
steps:
  1. System Preferences

  2. Network

  3. WiFi

  4. Edit location Add location

  5. Advanced

  6. TCP/IP

  7. Renew DHCP lease

  8. Click OK then Apply

D. reset NVRAM and SMC. attached are the articles for the steps do the these resets.

Reset NVRAM or PRAM on your Mac
How to reset the SMC of your Mac
(To know your machine has T2 Security Chip: OPTION-KEY+CLICK ON APPLE LOGO >> System information >> Controller)
As of 27 Nov, 2020 I was able to resolve Wi-Fi connectivity issue after upgrading to Big Sur 11.0.1 by resetting NVRAM

What you need to do is shut down your mac and immediately after you turn it back on, simply press and hold on the following keys simultaneously for ~20sec, then release the keys and proceed with login to the OS, hope this will help you too.


Option + Command + P + R




The way I believe I fixed my problem was resetting the IP address to something similar to your original one.
I also went on finder and typed in VPN and deleted all files and my MacBook seems to be working but sometimes the connection is dropping out.
In the 12 days since i upgraded to Big Sur, i have had 2 incidents of being unable to connect to the internet. I’m on the wifi ok and the wifi/internet connection is working with all other apple and android devices. BUT...the MacBook has no internet connectivity. I have found that one both occasions the solution is to reboot in Safe Mode and create a new network location. When I reboot the MacBook all is fine and dandy.

It’s frustrating because on both occasisions I lost over an hour’s productivity both times!

Also, I’m not technically minded, so the thought of doing these procedures is unnerving. One of the reasons I love Apple over Windows is that it takes away all this technical behaviour. I hope that Apple is not going down a slipper slope here!
Alhamdulillah, ternyata wifinya harus bersihkan VPN Global protectnya
I had same problem after Big Sur update on macbook air.
For me solved by
  1. Goto Network Preferences -> Advanced -> TCP/IP

  2. Note that IPv4 Address

  3. Configure IPv4 - > Select Using DHCP with manual address

  4. Enter the random IP address near to Default IPv4 Address you got in step2

Example -> If Default 192.168.1.202 change it to something like 192.168.1.204
Note ->. Do not go above the IP range of 255
I deleted my VPN and it seems to now work.
Uninstalling VPN seemed to have fixed it for now. None of the other solutions above worked

Tried:
PRAM reset
Booting into safe mode and adding a new Network Location
Changing the name of the Wifi connection
After updating to Big Sur 11.0.1 I also have no internet on my MacBook Pro 2016. Tried everything posted here. Please help...
::UPDATE::
Well, this seems to have been a temporary solution because I'm no longer able to get back on the internet. WTH APPLE!!!


I also experienced no internet after upgrading to Big Sur OS. The earlier post by @axolotl solved the issue for me: "follow the steps on this post apple.stackexchange.com/questions/284581/wipe-all-wifi-settings-from-macbook" (thanks, @axolotl)_
I also experienced no internet after upgrading to Big Sur OS. The earlier post by @axolotl solved the issue for me: "follow the steps on this post apple.stackexchange.com/questions/284581/wipe-all-wifi-settings-from-macbook" (thanks, @axolotl)
I'm having the exact same issues. I never used to have connectivity issues. My iPhone 11 MaxPro is constantly dropping now, my MacBookPro has become slow and unresponsive at times.... no one is talking about it.
Ok, click on your system preferences icon, then click on network - a page will open, on the column on the left side click on Wi-Fi. On the right hand side after clicking on WI-Fi you will see the information that you are looking for. Also, at the bottom of that page there is a box that can tick to
show Wi-Fi status in menu bar. Hope this help!