Xcode 12 is slow when launching apps (even sample projects)

Running a project from Xcode 12 seems to be very slow during launch. Even the example projects from Apple.

Basically it feels as if the app is stuck on the launch screen?

However, if I unplug from my Mac and just launch via tapping on the App icon, it's super fast.

Anyone is having the same issue?

23 Replies

This isn't Xcode 12 specific.

Deleting the contents of ~/Library/Developer/Xcode/iOS DeviceSupport seems to be the fix (worked for me just now):
https://developer.apple.com/forums/thread/123068?answerId=420683022#420683022
Xcode 12.3 causes this problem for me. Unpairing devices does not resolve the problem.
In my case removing all exceptions break point works fine
Still an issue.
its also could be instruments cache problems
This worked for xcode - 12.2 beta and IOS 14.2

Untick "Debug executable" from below paths worked for me.
  1. Product -> Scheme -> Edit scheme -> Select Run (left column) -> untick "Debug executable"

  2. Product -> Scheme -> Edit scheme -> Select Test (left column) -> untick "Debug executable"

Then close and run again.
for me, https://stackoverflow.com/questions/63929122/slow-app-launch-time-after-updating-to-ios-14-and-xcode-12
  1. In the XCode menu, Go to Product > Scheme > Edit Scheme

  2. Open the Info tab

  3. Uncheck the Debug executables checkbox

has given.
Still a problem. Xcode Version 12.0 (12A7209)

Per advice here, I deleted the iOS 14 folder inside ~/Library/Developer/Xcode/iOS DeviceSupport.  
(My iPhone is now on 14.0.1, so I left the 13.7 folder alone.)

It took a long time for Xcode to "copy cache files" from the iPhone but once that finally got done, normal build-and-run behavior is back. Nice and snappy.
I've been having the same issue since updating to Xcode12 and Xcode12.0.1 didn't fix it. It takes more than a minute from build successful to the app finally completing the launch because it's always stuck on this white screen.
Same issue for me. I had to do these instructions 2 times before the app would launch without hanging for a minute.

1) Unpair your phone from xcode
  • Launch xcode with your phone not plugged in
 - plug your phone in
  • under devices in xcode, unpair your phone
2) stop xcode
3) run these
rm -rf ~/Library/Developer/Xcode/iOS\ DeviceSupport
rm -rf ~/Library/Developer/Xcode/iOS\ Device\ Logs
rm -rf ~/Library/Developer/Xcode/DerivedData
4) start xcode
5) plug phone in
Deleting the ~/Library/Developer/Xcode/iOS DeviceSupport directory content did not work for me. And unpairing the devices over the "Devices and Simulators" panel was not helping either. After successfully loading and running the project on Xcode 12, the app hangs nearly a minute on the app launch image and then run perfectly without errors. The long time is enoying and I hope to find a solution soon! I had this issue since Xcode 12 and iOS 14.
Deleting the ~/Library/Developer/Xcode/iOS DeviceSupport directory for iOS 14 did not work for me.
Same issue!
1) For simulators run iOS14, delete folders inside ~/Library/Developer/Xcode/iOS DeviceSupport/ (folder's name started with 14.0).

2) For devices run iOS14, select Xcode window tab, click Devices and Simulators, find your device, right-click to unpair the device

https://stackoverflow.com/questions/63929122/slow-app-launch-time-after-updating-to-ios-14-and-xcode-12
This still happens. I just spent 12 hrs!!!! downloading Xcode 12.01 from the store to replace v12. Now app launches to device take 2 1/2 minutes after launch screen appears. Deleting the specific iOs DeviceSupport folder for the device's version of iOS did the trick. After the folder deletion, Xcode reloaded the symbol tables from the device and all was well. App launch time now back to 1-2 seconds.