iOS 14.2 app crashes in arm64e devices if deployed via MDM

iOS 14.2 applications developed using Xamarin are crashing in arm64e CPU devices. These Xamarin apps are deployed using a Mobile Device Management tool(Airwatch or Microsoft Intune). However, the same iOS apps work fine in iOS 14.2 when it is installed via the App Store.

We have seen this issue in Xamarin iOS apps like-
Microsoft Azure
Microsoft Seeing AI, etc.

Steps to reproduce,
  1. Configure an MDM tool

  2. Deploy a Xamarin based iOS app to arm64e device (like iPhone 11)

  3. Launch the app after installation

Expected result:
The app should launch and work as expected

Actual result:
The app crashes after 20 seconds with the following error -
Exception Type: EXCBADACCESS (SIGKILL)
Exception Subtype: UNKNOWN0x32 at 0x0000000106464018
VM Region Info: 0x106464018 is in 0x106464000-0x106468000; bytes after start: 24 bytes before end: 16359
REGION TYPE START - END [ VSIZE] PRT/MAX SHRMOD REGION DETAIL
VM
ALLOCATE 106460000-106464000 [ 16K] rw-/rwx SM=PRV
  • --> mapped file 106464000-106468000 [ 16K] r-x/r-x SM=COW ...tid=969d6cc3

VMALLOCATE 106468000-1064e8000 [ 512K] rw-/rwx SM=PRV

Termination Reason: Namespace SPRINGBOARD, Code 0x8badf00d
Termination Description: SPRINGBOARD, <RBSTerminateContext| domain:10 code:0x8BADF00D explanation:process-launch watchdog transgression: application<com.microsoft.azure>:1696 exhausted real (wall clock) time allowance of 20.00 seconds | ProcessVisibility: Foreground | ProcessState: Running | WatchdogEvent: process-launch | WatchdogVisibility: Foreground | WatchdogCPUStatistics: ( | "Elapsed total CPU time (seconds): 24.050 (user 24.050, system 0.000), 20% CPU", | "Elapsed application CPU time (seconds): 20.001, 17% CPU" | ) reportType:CrashLog maxTerminationResistance:Interactive>
Triggered by Thread: 0

Thread 0 name: tid_407 Dispatch queue: com.apple.main-thread

Post not yet marked as solved Up vote post of MViquar Down vote post of MViquar
6.1k views

Answers

We have several thousand enterprise users who use a variety of MDM packages, including MobileIron, IBM MaaS360, Apple Configurator, AirWatch, and Microsoft Intune. ALL of them are experiencing this crash of our Xamarin.iOS app if the device is running iOS 14.2.
This bug is also extremely critical from my side.
Now more than 4000 devices (iPhone 11 and XR) at one of my customers, who uses Intune to deploy his Xamarin IOS custom app, are affected by this problem.
I also reroduced this issue.
I have referenced my public store apps and ABM custom apps (same Xamarin IOS core as public app) in my Intune portal.
I have successfully deployed these applications on 13.x and 14.1 devices.
I then migrated the devices to 14.2 and reproduced the problem: The splash screen is displayed for a few seconds, then the application dies.
Iphones 7,8 & X are not affected. I reproduced on 11 and XR.
NOTE : deploying an IPA works properly
Post not yet marked as solved Up vote reply of 6RiL Down vote reply of 6RiL
We are experiencing the same thing with our MDM and an app we use. Has anyone found a solve?
We are experiencing the same issue. We can confirm that the issue occurs when deploying a Xamarin.iOS AppStore app via MDM to an arm64e device running iOS 14.2.

Tested devices that are affected:
iPad Pro 11" 2nd gen
iPad Pro 12.9" 3rd gen
iPad 8th gen

Tested devices that are not affected:
iPad 5th gen

Same issue here many users are impacted.
Same here, about 100 corporate iPads managed with Intune cannot use our custom Workforce Management app anymore. This is really impacting us badly.

Please share any workaround that will be available.
Hello all,
We are also in the same position. Unfortunately our application is used by COVID testing sites across the United States, this problem has caused massive headaches for their front line staff.

Please look at this as a priority.

Thank you
We are experiencing this same issue with several users distributing the Field Service Mobile (Xamarin) app using Microsoft Intune. We are at about 50% success rate with iOS 14.2.
We have several users facing this issue and its impacting our Business.
We are experiencing the same crash with our MDM package, MobileIron.
Even we are facing the same Issue with Microsoft Intune
This bug is extremely critical for us as well. Several customers reported this problem for different MDM-Systems like MobileIron and Baramundi.
If your app is published as a Custom App (as most of ours are) and therefore not visible on the App Store, using redemption codes from Apple Business Manager (versus relying on Managed Licenses) also allows the app to launch. This may be a temporary option for business users that have already upgraded to iOS 14.2 and cannot launch apps distributed via MDM using Managed Licenses. Obviously with a large number of users this may be prohibitive, but with a relatively small number of users sending them redemption codes may be an option.
We also are experiencing the same issue with our healthcare apps. A variety of MDMs, the same app was functioning properly through the MDMs on previous iOS versions and continues to function in iOS 14.2 when loaded through the App Store.
This is so frustrating. This is affecting all our customers that deploy our iOS app via IBM MaaS360 to arm64e devices running iOS 14.2