MacOS Big Sur Issues

I reset my laptop to the default settings normally (I’ve done it before), but when I tried to reinstall MacOS Big Sur it says “No users available for authorization”. I’ve tried making a new admin through terminal in recovery mode but it isn’t working and Command+S to get to single user mode doesn’t work either. Any ideas on how to fix this?
Post not yet marked as solved Up vote post of Gberenise Down vote post of Gberenise
27k views

Answers

I also have the same issue. Please help. Thanks.
Just had this happen to me and noticed your question during my search. I was able to fix it by allowing it to boot into normal mode where it asked me to use my apple account to activate the mac, before I "quit recovery assistant" button (IIRC that's what it said) I chose "Erase Mac" from the menu up top. That took a few seconds, rebooted and I was able to continue a fresh install, this time without the “No users available for authorization” message.
  • This solved also my problem. Huge Thanks.

Add a Comment
You are my life saver! Thank you so much. It Works!
Okay, same issue here, but I'm not given the option for "normal" mode. It just goes into recovery mode straight away. Any ideas?
@rhweinberger "normal" mode in this case was recovery mode. I had just erased the "Macintosh HD" partition because it was just full of crap and I wanted a fresh start. On the screen where you log into your apple account, that's where you'll find the "Erase Mac" option. I don't know if you have to do it before or after you sign on, but you should not exit from the dialog after you sign on. The option is on the menu bar at the top of the screen. Good luck!
I just spoke with Apple support about this issue and they had me go to terminal and then type resetpassword and then I erased the mac and was able to reinstall mac os big sur. Part of the issue was that I had erased the macbook air without creating any user accounts. After it reboots you will need to connect to wifi again.
I’m having this same issue, only after I type resetpassword into terminal it is saying reset password failed and that there are no users on this volume to recover. Not sure what to do next
Having the same issue on my end as well. Accidentally wiped out the disk on my M1. Now getting the “No users available for authorization” message when I try to reinstall OSX.

Tried:
  • Terminal (resetpassword)

  • Terminal (rm "/Volumes/Macintosh HD/var/db/.AppleSetupDone")

No luck...

Add a Comment
I had the same issue @tgermaneri answer helped me thank you so much it is reinstalling now. I never had that in an other Mac .
  • Agreed, the answer from tgermaneri worked. Note that the Erase Mac option is available right away in the Recovery area, even before I entered in my username and password.

Add a Comment
I had the same issue and tried
  • Terminal (resetpassword)

  • Terminal (rm "/Volumes/Macintosh HD/var/db/.AppleSetupDone")

As this was a fresh install and was happy to wipe all data -what worked for me was erasing the data drive as I had only erased the Macintosh HD drive. Please be careful to ensure you have a backup in place should you not be able to wipe everything before proceeding with this solution.

go to iCloud.com and erase the Mac then delete it from your account and then long press on power button for of the MacBook with M1 chip to get to reinstall the os
to reinstall macOS big sure on MacBook Air :
  1. utilities window choose Utilities > Terminal from the menu bar

  2. Type resetpassword in Terminal

  3. Click on the Reset Password box(any where)  and from menu bar select Recovery Assistant > Erase Mac from the menu bar

(even if there no user inside the box)
4. Click Erase Mac in the window that opens When done, your Mac will restarts.
5. follow the steps in wizard , Until you see Exit to Recovery Utilities.
6. select Reinstall Mac OS Big Sure

  • I literally registered on this forum just to tell you thank you so much for this post

  • thank you, your answer really helped

  • Thank you so much! Lifesaver

Add a Comment
I eventually managed to get around this by deleting all the volumes/partitions on the disk and starting from scratch.
The steps that worked for me is to delete both the "data" volume and "Macintosh HD" volume and create a new volume from scratch. Then the reinstaller stops complaining.
Delete both Data and macintosh HD and then shut down Disk Utility and reinstall Mac OS Big Sur. This option worked for me as well. All other solutions given, like using Terminal, did not work for me. Thanks protossor.
  • This worked for me! thank you leefe012.

Add a Comment