Trouble with installing cocoapods

I am getting the same error over and over again and I do not know why. I tried several ways to fix it, but nothing works.
Code Block sudo gem install cocoapods
Building native extensions. This could take a while...
ERROR:  Error installing cocoapods:
ERROR: Failed to build gem native extension.
    current directory: /Library/Ruby/Gems/2.6.0/gems/ffi-1.13.1/ext/ffi_c
/System/Library/Frameworks/Ruby.framework/Versions/2.6/usr/bin/ruby -I /Library/Ruby/Site/2.6.0 -r ./siteconf20201202-2686-t7m7nb.rb extconf.rb
checking for ffi.h... * extconf.rb failed *
Could not create Makefile due to some reason, probably lack of necessary
libraries and/or headers.  Check the mkmf.log file for more details.  You may
need configuration options.
Provided configuration options:
--with-opt-dir
--without-opt-dir
--with-opt-include
--without-opt-include=${opt-dir}/include
--with-opt-lib
--without-opt-lib=${opt-dir}/lib
--with-make-prog
--without-make-prog
--srcdir=.
--curdir
--ruby=/System/Library/Frameworks/Ruby.framework/Versions/2.6/usr/bin/$(RUBY_BASE_NAME)
--with-ffi_c-dir
--without-ffi_c-dir
--with-ffi_c-include
--without-ffi_c-include=${ffi_c-dir}/include
--with-ffi_c-lib
--without-ffi_c-lib=${ffi_c-dir}/lib
--enable-system-libffi
--disable-system-libffi
--with-libffi-config
--without-libffi-config
--with-pkg-config
--without-pkg-config
/System/Library/Frameworks/Ruby.framework/Versions/2.6/usr/lib/ruby/2.6.0/mkmf.rb:467:in `try_do': The compiler failed to generate an executable file. (RuntimeError)
You have to install development tools first.
from /System/Library/Frameworks/Ruby.framework/Versions/2.6/usr/lib/ruby/2.6.0/mkmf.rb:585:in `block in try_compile'
from /System/Library/Frameworks/Ruby.framework/Versions/2.6/usr/lib/ruby/2.6.0/mkmf.rb:534:in `with_werror'
from /System/Library/Frameworks/Ruby.framework/Versions/2.6/usr/lib/ruby/2.6.0/mkmf.rb:585:in `try_compile'
from /System/Library/Frameworks/Ruby.framework/Versions/2.6/usr/lib/ruby/2.6.0/mkmf.rb:1109:in `block in have_header'
from /System/Library/Frameworks/Ruby.framework/Versions/2.6/usr/lib/ruby/2.6.0/mkmf.rb:959:in `block in checking_for'
from /System/Library/Frameworks/Ruby.framework/Versions/2.6/usr/lib/ruby/2.6.0/mkmf.rb:361:in `block (2 levels) in postpone'
from /System/Library/Frameworks/Ruby.framework/Versions/2.6/usr/lib/ruby/2.6.0/mkmf.rb:331:in `open'
from /System/Library/Frameworks/Ruby.framework/Versions/2.6/usr/lib/ruby/2.6.0/mkmf.rb:361:in `block in postpone'
from /System/Library/Frameworks/Ruby.framework/Versions/2.6/usr/lib/ruby/2.6.0/mkmf.rb:331:in `open'
from /System/Library/Frameworks/Ruby.framework/Versions/2.6/usr/lib/ruby/2.6.0/mkmf.rb:357:in `postpone'
from /System/Library/Frameworks/Ruby.framework/Versions/2.6/usr/lib/ruby/2.6.0/mkmf.rb:958:in `checking_for'
from /System/Library/Frameworks/Ruby.framework/Versions/2.6/usr/lib/ruby/2.6.0/mkmf.rb:1108:in `have_header'
from extconf.rb:10:in `system_libffi_usable?'
from extconf.rb:42:in `<main>'
To see why this extension failed to compile, please check the mkmf.log which can be found here:
  /Library/Ruby/Gems/2.6.0/extensions/universal-darwin-19/2.6.0/ffi-1.13.1/mkmf.log
extconf failed, exit code 1
Gem files will remain installed in /Library/Ruby/Gems/2.6.0/gems/ffi-1.13.1 for inspection.
Results logged to /Library/Ruby/Gems/2.6.0/extensions/universal-darwin-19/2.6.0/ffi-1.13.1/gem_make.out

Something might be wrong with Ruby, but I could not figure out what I should do to fix it.

Accepted Reply

Depending on some aspects this might work for you, if you don't mind using the "SUDO" command:

sudo gem install -n /usr/local/bin cocoapods -v 1.8.4

Latest CocoaPods 1.10.0 won't work.
  • Having same issue with my mac, anyone please help...

  • I really don't know how to thank you I spent 4 hours trying to solve this problem Thank you with all my heart

  • Man thanks. You are a lifesaver.

Replies

I also had this exact same error when trying to install cocoapods on a new machine today. Not sure why? Any help would be awesome :)
Bump, exact same issue. MacOS 11.0, Ruby 2.6.0. Can't find any fix anywhere.
Greetings!

Solution :-

1) Install homebrew via terminal.

2) After homebrew is successfully installed, type in the terminal '$ brew install cocoapods'

Done.

  • worked for me.

  • Thank you my man, it solved my issues :)

  • Thanks. This worked for me

Hi,

this works for me.

sudo xcode-select --switch /Applications/Xcode-beta.app/Contents/Developer

explain solution
sudo xcode-select --switch <path to xcode>/Contents/Developer


=D

Depending on some aspects this might work for you, if you don't mind using the "SUDO" command:

sudo gem install -n /usr/local/bin cocoapods -v 1.8.4

Latest CocoaPods 1.10.0 won't work.
  • Having same issue with my mac, anyone please help...

  • I really don't know how to thank you I spent 4 hours trying to solve this problem Thank you with all my heart

  • Man thanks. You are a lifesaver.

Thank you all ! With sudo gem install cocoapods it worked!

Same problem - XCode 12.3 on Mac OS 10.15.6.

Tried the CocoaPod mac app from the CocoaPods about page, which did have an option to install the command line tool, but it was version 1.1.x for some reason....

Brew install did the trick, and installed 1.10.0.
same issuse and i tried "brew install cocoapod "but it is intsalling version 1.5.2 and for my project to run properly it required version 1.9.0 and above
i even tried "sudo gem intsall cocoapods" and also tried modifying .bash_profile file method, none of them worked.. help me
  • hai @Me-Human has your problem been solved?

Add a Comment

am having the same problem , using: brew install cocoapod  , would install version 1.5 and I need version 1.10 even when I tried brew it installed version 1.5????? every time I upgrade , it gives me same error msg:

To see why this extension failed to compile, please check the mkmf.log which can be found here:

  /Library/Ruby/Gems/2.6.0/extensions/universal-darwin-21/2.6.0/ffi-1.15.4/mkmf.log

extconf failed, exit code 1

I solved this problem with using brew

You need to:

  1. install LATEST version of brew (https://treehouse.github.io/installation-guides/mac/homebrew)
  2. then use "brew uninstall cocoapods"
  3. install the latest version of cocoapods using "brew install cocoapods" (You must verify installed version with github version https://github.com/CocoaPods/CocoaPods/releases/tag/1.11.2, they must match)
  4. overwrite link to cocoapods with "brew link --overwrite cocoapods"
  5. check the version of cocoapods "pod --version"
  6. done, You have the latest version of cocoapods installed
  • solo incie sesion en esta web para agradecerte por la solución, realmente excelente amigo. TY SM

  • it works in macOS 11.6 Big Sur

  • for me its worked , i just update the cocoaPods key manually using this "sudo rm -rf /usr/local/Cellar/cocoapods/1.10.0"(its just shows in error or warning section) after"brew install cocoapods" method.THANKS you bro and brew ! (macOS Catalina - 10.15.7 and Xcode - 12.4)

Add a Comment

Good that you showed the solution. I've been sitting on this problem for a long time and nothing helps. Your solution is good thanks

[!] Xcode - develop for iOS and macOS   ✗ CocoaPods installed but not working.     You appear to have CocoaPods installed but it is not working.     This can happen if the version of Ruby that CocoaPods was installed with     is different from the one being used to invoke it.     This can usually be fixed by re-installing CocoaPods.    To re-install see    https://guides.cocoapods.org/using/getting-started.html#installation for    instructions.

try installing cocoa pods using brew

$ brew install cocoapods

after it finishes downloading

$ pod --version

if it shows the version then cocoapods is installed