Installation is slow on M1 machines

Hi,
we are experiencing installation is slow on M1 platform. what could be the reason. We tried on multiple M1 hardwares.

Regards
Post not yet marked as solved Up vote post of OneTwoThree Down vote post of OneTwoThree
4.8k views
  • I've been having this issue too since getting my M1 MacBook Pro at the end of 2020. App store updates always get to 75% very quickly (I assume due to my high download speed) but then take a very long time for the last 25%. Every time there is an Xcode update, it gets to 75% in just a couple minutes, but then the last 25% takes hours. There is no feedback in the UI about what it is doing, it just shows the blue circular progress bar around the stop button. It happens every time without fail, this most recent time on macOS Monterey 12 Beta 8. I have the 16 GB RAM + 1 TB storage model, and I have 911 GB of free unused storage. Why is it that the fastest ever product from Apple has the slowest ever app install speeds?

Add a Comment

Answers

Hi,

I've been experiencing the same. All App store installations (new apps as well as updating existing ones) takes insane amount of time. The download is super quick but installation takes forever.

Have already reset MacOS once.

Please share a solution.

Thanks!
I'm experiencing the same. Xcode downloaded quickly but now taking 3+ hours & not installed yet :(
Same. Affinity Photo took 20 minutes to install on my new MacBook Air M1 (and 20 minutes for the subsequent update), whereas it took less than 5 on my 8 year old iMac. It's been over an hour and 15 minutes for Xcode and it's still not done...
It'll become much slower when your storage is around 10 - 15% as the spindump process keeps running more often!

I only noticed this when the storage is low while opening < 15 Chrome tabs, 10 Firefox tabs, VScode + 2 or 3 lightweight applications - not even openning XCode + Simulator (Memory: 16G - M1)
  • But my 1 TB storage has 911 GB free and unused, that can't possibly be the reason it takes hours to install Xcode.

Add a Comment

I'm having the same issue. My M1 MacBook pro will sometimes take 8 hours to update xcode. Very frustrating.

I've been having the same today updating Numbers, Pages and iMovie. Each one has taken many hours to install!

Same here, i have an air m1 512gb, it's super fast doing everything but every xcode update take too many hours. Any solution?

My feedback is the same, Macbook M1 Pro 14'', MacOS 12.1 Monterey.

Xcode initial installation took really long, I thought it was a first time delay. Now I'm updating and already waiting for 2 hours to complete, still working.

Same here it takes long for many apps in the installation process. and for the Xcode took more than 6 hours!!

Also having this issue with Xcode, and many other apps. Install took almost 9 hours, tried multiple times/multiple reboots... The M1 architecture experience has been terrible, anything that runs through the Rosetta translation is unusably slow. Processes that took 5-10 seconds now take 10+ minutes. I really hope they go back to x86/64 architecture....

Same here, with Macbook M1 pro 14, MacOS 12.1 Monterey.

Same here, M1 pro baseline, I don't know why but this happens only on apple application (xcode, garageband, imovie for now). I think that is only a software issue anyway.

same here, Xcode installing for past 1 hour on MBA m1