Issue with opening IOS Simulator

I am developing an App in React Native for this i need Xcode. However when i start my Expo Developer Tool Metro Bundler There when I click Run IOS Simulator. Always From the VS Code Terminal I am getting the same message like Xcode needs to be installed (don't worry, you won't have to use it), would you like to continue to the App Store? However I have already Xcode installed the after that when i type Y it takes me to App Store where i find the option open Xcode it's because i have already installed Xcode. Please guide me through this because i am not able to see my App on IOS devices
Post not yet marked as solved Up vote post of TasaduqHaqaq Down vote post of TasaduqHaqaq
  • I had the same issue because I am using Xcode-beta so I ran this command on my terminal sudo xcode-select -s /Applications/ and it worked

  • The comment above worked for me, but instead of, I only wrote

  • me too - sudo xcode-select -s /Applications/ 🙏


I have the same issue... Yesterday, I Initialized macOS and installed other software like Xcode. Later, this issue occurs. I think my version of the software is the latest.
any luck with this? I'm experiencing the same issue
I ran into this same problem and resolved it in the following steps.
  1. ) Open Xcode

  2. ) go to preferences

  3. ) go to locations tab

  4. ) select an Xcode version in the select labeled "Command Line Tools"

Thank you, KerstingJosh! It worked! :)
@KerstingJosh  , it Works !
Thank you

thank you!!

this is the correct way !! Open Xcode, then choose "Preferences..." from the Xcode menu (or press ⌘+,). Go to the Locations panel and install the tools by selecting the most recent version in the Command Line Tools dropdown.

thank you!!

Thank you, it worked.

It still doesn’t work for me. What should I do?

Open a new terminal using Z shell (zsh) in VS Code > run the expo start again > i