“iPhone” is busy: Making the device ready for development

“iPhone”: is busy: Making the device ready for development Xcode will continue when “iPhone” is finished.

Post not yet marked as solved Up vote post of allen77 Down vote post of allen77
  • Do you have anything to ask about the message?

  • "iPhone 7 IOS 15" : Xcode 13.0.0

    iPhone 7 is busy: Making iPhone 7 ready for development Xcode will continue when iPhone 7 is finished.

    Could not install on iPhone 7, and Developer option does not appears in the settings menu. is there any way to fix this.

  • I was able to solve this using the StackOverflow question mentioned by @Claude31 below. In my case, I opened "Devices and Simulators", then unpaired the device, closed Xcode, opened Xcode, and re-paired the device.


I have tried every single thing, but xCode 13.0 or xCode 13.1-rc1 both can not install debug app on the iphone 7 iOS 15.1 or 15.0.2. tried deleting  derived data,, restarted xCode and iPhone multiple times. still no success .

I have exact same issue. But I cannot still found solution.

I simply I rebooted everything. When opening Windows > Devices, iPhone was stated as busy.

After 10’, that was cleared.

You could also have a look at this older thread:


Got this from another forum post and worked for me. Under build settings make sure the IOS Deployment Target matches the IOS version on your phone. If you have an older iphone that cannot be updated anymore, this might not work.

I have an app where under Build Settings shows the Project and two Targets, I matched both these to my IOS version of 15.0 and the error went away and the build completed.

This usually means that Xcode is busy copying debug symbols from the device. This can be impacted by wifi network condition if debugging wirelessly or by the quality of the lightning cable and hubs used to connect the device. Please be sure to connect your iOS device directly to your host mac with an Apple-brand lightning cable to eliminate those variables.

I try with my iphone 7 (ios 15) on  Xcode 13.0.0 same problem, with ipad (ios 15) on  Xcode 13.0.0 no problem. In both test with same cable

I have the same issue. iPhone 7, worked great with iOS 14 but I 'upgraded' to iOS 15.4 and also upgraded Xcode to 13.3 and I just get an endless 'waiting' message for the phone. I have rebooted everything, reinstalled iOS on the phone several times, nothing has helped.

(It sure would be nice if Apple had a way for us to install old version of iOS on a device. Not everyone can afford to leave a dev phone on an old OS release when so many new releases come out. Then I could have fixed this problem in an hour instead of wasting the better part of an day on it.)

  • Same configuration (iPhone7, ios 15.4), same issue here from several month... nothing work for me...i don't have Apple watch...I don't understand the problem...

Add a Comment

Same configuration (iPhone7, ios 15.4), same issue here from several month... nothing work for me...i don't have Apple watch...I don't understand the problem...

We got the same issue with iPhone 7 and iPhone XS, both iOS 15.4.1 and Xcode 13.3.1

I am also still having the exact Problem with an iPhone 7 (iOS 15.4.1) Xcode 13.3.1. I already have waited for 12 hours for it to finish but its still not done. This does seem to be a bug.

Has anyone submitted a feedback request for this error? I haven't been able to use my iPhone for debugging in almost a year.

this is clearly a bug

iPhone 7 (iOS 15.4.1) Xcode 13.3.1. Same for me. I am having this problem for days. I even left the process during the entire night but at the morning same status.

  • In my case for Xcode 13.3.1, this says my iphone is set up. My deployment targets are the same as the version of my iphone, 14.4, and no amount of waiting, rebooting the iphone and the mac, or restarting Xcode will make the app install from its archived location.

    Makes it kind of difficult to see problems that only app reviewers can see.

Add a Comment

iPhone8(iOS14.8.1) Xcode13.0. Unpaired apple watch, it worked.

Same issue with iPhone 7+ on iOS 15.4 and Xcode 13.3.1