Xcode 13.2 - Internal error : Missing Package Description Module

  • Same issue here. Same Xcode and OS versions, on M1. I tried removing and re-adding the package, but that didn't fix it.

  • :( Same issue. Even tried creating a brand new Swift Package (blank w/one test) and still seeing the issue, so it doesn't seem project specific...

  • Same issue here.

Apple Recommended

  • If they have fixed it, why isn't it available as an update via the usual Software Update in System Preferences?

  • I needed to click UPDATE on the Xcode 13 page in the App Store. Maybe this was because the server was very busy at that time. Anyway, 13.2.1 is working now.

  • Now the app store update is stuck in going from 13.2 to 13.2.1, looks like I have to delete the previous store version.


Same issue, "Internal error: missingPackageDescriptionModule". Tried removing / re-adding the package dependencies but xcode13.2 is stuck in the "Preparing to validate..." stage. issue on all projects (iOS and MacOS) on intel iMac & mbp M1max. both machines upgraded to Monterey 12.1.

  • I have this exact same behavior...can't figure it out.

  • Same problem obviously! The truth is apple doesn't want us to use packages! Seriously, two betas and final release of xcode 13.2. Soon the 13.2.1great job, but 13.3 is wold be great! I put on the agenda another 2 hours lost between download and installation! Yeah! 🤪🔫

Add a Comment

Thank you for your replies, that's a bit reassuring to read that my project isn't the only one affected by this issue even though I'm sorry for you lads.

I'm guessing we're probably due for a minor Xcode update to fix this ? I'm on my way to reinstall 13.1 and I'd advise you to do the same for the time being. Hope they'll get it fixed soon !

Same issue here. I've used Xcode 13.2 beta 2 with macOS 12.0.1 without this issue.

FWIW, xcode 13.2 also started sending me those errors related to github.com certificate validation.

I have the same issue with the AppStore Version. The 13.2 RC works fine for me.

I have a similar issue. I am using a workspace with many projects and packages, and when updating today to xcode 13.2 all the targets to my packages disappeared and now my projects won't build. The error was missingPackageDescriptionModule. Tried recreating the workspace but still when adding packages, local or remote, their targets are not created.

Didn't have any problems with the betas of xcode 13.2.

Same issue here running the 2020 M1 13" mbp

  • same here, I feel this M1 is the worst from apple.

  • @esePaul It's happening on my 2017 Intel MBP too, FWIW.

Add a Comment

Same issue here!

Me, too. Apple!!!

Same issue, no Swift Packages will load, I can't believe they released this crap, they just took down all their developers!

  • Maybe they want us to take a break. Stretch, relax, go for a walk. Breathe some fresh air. Maybe take the rest of the day off.

Add a Comment

If you can, downgrade to 13.1, it works there. As @waqar said, the 13.2RC works fine as well, at least for me.

Same issue here!

Same issue for me!

To add insult to injury if you create a brand new Xcode project and try to add ANY package from Github the process hangs immediately on "Preparing to validate"

Come on Apple! Are you for real?

  • For me I accessed it via the direct Github URL in the search box, it asked me if I wanted to trust it, after clicking on "Trust" it seemed to add it. Definitely a bug though.

Add a Comment

Running into the same issue on our project as well.

Make sure to file a Feedback Request:

Mine is FB9807970

Same issue here, Xcode 13.2 on Monterey 12.0.1.

I was able to get it to go away for a few hours, not sure how exactly, may have involved deleting and re-adding the package manually. Also I cleared derived data, etc. Now it's back anyway, and I can't communicate with the package server, so I can't re-add it.

  • Probably makes sense for Apple to have separate downloads for the intel & Arm versions of Xcode, the download size just keeps doubling.

Add a Comment