Xcode 15 linking error

Hi, I am getting a linking error when building my app to run against an iOS17 device, using Xcode15. Same project builds and runs fine with Xcode 14 and iOS16. The linking error just says:

clang: error: unable to execute command: Segmentation fault: 11 clang: error: linker command failed due to signal (use -v to see invocation)

Not sure what I should try to overcome this. I can't run my app on an iOS17 device. It builds, links and runs just fine on a simulator.

Post not yet marked as solved Up vote post of zulfishah Down vote post of zulfishah
  • I had a similar problem

    Ld *** clang: error: unable to execute command: Segmentation fault: 11 clang: error: linker command failed due to signal (use -v to see invocation)

  • My issue had to do with some SPM repositories, and how they were being reset to v1.0 when set to "Exact Match" to an older version. This seems to be a bug with Xcode 15 Beta1 (FB12283412). Setting it 'Up to Major Version' from 1.0 to the last acceptable version worked for me.

  • Working now after I added "-ld64" to "Other linker Flags". Thank you @songme


I have the same problem.

  • Adding the "-ld64" flags helps, but then I can't use the project with Xcode 14.3.1. I get the error "library not found for - ld64". It needs to work with Xcode 14.3.1 because the Azure CI uses it. I hope this issue will be fixed soon.

  • I need Xcode 14.3.1 too

Add a Comment

I have the same problem.

Getting the Same issue any one got an Answer?

I have the same problem.

Having the same problem.

There is an issue tracking this in the firebase-ios-sdk repo. I'm trying to figure out it if this is only caused by Firebase. Is anyone using Firebase? Is anyone not using Firebase, but seeing this issue?

If you are using Firebase and seeing this issue, please feel free to contribute to the discussion in the above linked issue. Additionally, reverting to Firebase 10.7.0 should unblock your development until a solution is found. Thanks!

  • I have this same issue without using firebase but got solved by @songme 's answer

  • I got it with firebase too, but got solved it by adding "-ld64" to "Other linker Flags" as @songme mentioned. Thanks @songme and his references.

Add a Comment

Same issue.

other link flags add "-ld64"

  • Thank you it's working now after adding the above flag you save my day.

  • thank you

  • Working now

I have the same problem.

I see the same issue, no firebase in use. Filed as FB12236547. Adding -ld64 (using the old linker?) works fine for now.

other linker flags add "-ld64" ,works for me

Filed as FB12236547.


using the old linker?

Yes, that’s what that flag does. I just updated An Apple Library Primer for some of the backstory to this.

This definitely looks like a bug in ld_prime. Regardless of whether or not the input library is malformed, the linker shouldn’t crash |-:

Share and Enjoy

Quinn “The Eskimo!” @ Developer Technical Support @ Apple
let myEmail = "eskimo" + "1" + "@" + "apple.com"

I have the same problem.

We have same problem.

We had the same problem and adding -ld64 “Other linker flags” fixed in in Xcode 15 beta 2. Thanks!!!