Constant "Your session has expired" (error 1100)

Trying to do a CLI build with XCode (using NativeScript).


Was working fine a couple days ago. However, now I cannot get past this error when trying to build:



DTDeviceKit: deviceType from 7c64d8a014fd573ca3623ef80b158e57e7aea7c5 was NULL

2018-05-07 11:57:54.696 xcodebuild[14808:865317] DVTPortal: Service '<DVTPortalViewDeveloperService: 0x7fe4e17686d0; action='viewDeveloper'>' encountered an unexpected result code from the portal ('1100')

2018-05-07 11:57:54.696 xcodebuild[14808:865317] DVTPortal: Error:

Error Domain=DVTPortalServiceErrorDomain Code=1100 "Your session has expired. Please log in." UserInfo={payload=<CFBasicHash 0x7fe4e242ed70 [0x7fff9115faf0]>


Whenever I open XCode and to go preferences->account, my team account already reports "Session has expired". I log in successfully, then close Xcode, then login again, and once again it says the "Session has expired".


Enabled two factor authentication hasn't helped. I get the identical error from two separate machines (Mac Mini and MacBook Air). Using latest High Sierra OS and XCode.


My developer accounts logs in fine to the developer portal on Apple's Developer site, iTunes connect, etc..

Post not yet marked as solved Up vote post of julian87 Down vote post of julian87
16k views

Answers

Was this issue resolved? And if so how was it solved? Thanks

Same here... does anyone know why this is happening?

I have the same issue using Xcode 10, and I cannot find a fix... 😟 Please help!

I am also seeing this error on our continuous integration (Jenkins) servers. It works fine when invoked manually, but it has a problem connecting if it's invoked via a Jenkins job. Any help would be greatly appreciated! It's such a pain to manually keep provisioning profiles in sync on multiple CI/CD servers because of this error

I am having the same issue, running command on the mac terminal locally works, but executing the same command remotely using a shell script fails with the error. Other commands like build and archive works without any errors.


Issue encountered on when export achive is executed.


Please advise what parameters are required to execute successfully.


xcodebuild -exportArchive -archivePath ios/build.xcarchive -exportOptionsPlist exportOptions.plist -exportPath ios/build


2018-12-10 05:41:11.004 xcodebuild[92132:228593] DVTPortal: Service '<DVTPortalViewDeveloperService: 0x7fa4f49f78b0; action='viewDeveloper'>' encountered an unexpected result code from the portal ('1100')

2018-12-10 05:41:11.004 xcodebuild[92132:228593] DVTPortal: Error:

Error Domain=DVTPortalServiceErrorDomain Code=1100 "Your session has expired. Please log in." UserInfo={payload=<CFBasicHash 0x7fa4f4a85bb0 [0x7fff952ebb30]>{type = mutable dict, count = 9,

entries =>

0 : responseId = <CFString 0x7fa4f4a7fe30 [0x7fff952ebb30]>{contents = "96dd90f2-0d7d-4901-b7b2-ca2d2deb5509"}

2 : <CFString 0x7fff9520eb98 [0x7fff952ebb30]>{contents = "protocolVersion"} = QH65B2

3 : <CFString 0x7fa4f45e19e0 [0x7fff952ebb30]>{contents = "requestUrl"} = <CFString 0x7fa4f47c5c60 [0x7fff952ebb30]>{contents = "https://developerservices2.apple.com/services/QH65B2/viewDeveloper.action"}

6 : <CFString 0x7fa4f45d4280 [0x7fff952ebb30]>{contents = "userLocale"} = en_US

8 : resultCode = <CFNumber 0x44c37 [0x7fff952ebb30]>{value = +1100, type = kCFNumberSInt64Type}

9 : userString = <CFString 0x7fa4f4ab4e90 [0x7fff952ebb30]>{contents = "Your session has expired. Please log in."}

10 : <CFString 0x7fa4f45ee740 [0x7fff952ebb30]>{contents = "resultString"} = <CFString 0x7fa4f45e8160 [0x7fff952ebb30]>{contents = "authentication.failed"}

11 : httpCode = <CFNumber 0xc837 [0x7fff952ebb30]>{value = +200, type = kCFNumberSInt64Type}

12 : <CFString 0x7fa4f45f4b60 [0x7fff952ebb30]>{contents = "creationTimestamp"} = <CFString 0x7fa4f45cc290 [0x7fff952ebb30]>{contents = "2018-12-10T13:41:10Z"}

}

, NSLocalizedDescription=Your session has expired. Please log in.}




Please help

I was able to fix this by unlocking the keychain remotely with

security unlock-keychain -p PASSWORD

A reboot of the Mac resolved this in my case.

im looking for some assistance on this one too please...

Has anyone fixed this issue? We're seeing it constantly in our CI server when kicking off jobs.

Still happening in Oct 2019. I've tried all of the suggestions above with no luck. If anyone has a solution or workaround, please share!

I was also troubled by this. My CI jobs stopped working even though and I was using


security unlock-keychain -p PASSWORD


However, later I found that my password was not updated after the last time I changed it, so for anyone that is having issues with this, double-check that your password is correct!

In my case, my certificate was expired, so the company extended it and I had to update it on Xcode.

It was solved by going to Xcode -> Preferences -> Accounts -> Select the user related to the project -> Manage Certificates and then I pressed the "+" button on the .bottomLeft to and the updated certificate.

Thanks Jujuba. This solved the problem for me. In my case it was re-logging into the apple developer account.