"Not enough free space" when trying to install XCode even though there's ~7x more free space than required

The title says it all...

I am trying to install XCode, constantly getting that message, no matter what I try. Currently I have 41+ GB free space, XCode requires 6.1 according to App Store.


Please suggest how to solve this issue.


Thanks a lot in advance!

  • Me also getting same problem whenever I try to update Xcode. At least it should show update size of any app. It doesn't show update size for any app in App Store. How can we know which update is consuming how much data? If it explicitly asks that I want exactly this much of space for installing updates then we can do something about it. Without showing update size it simply goes on asking for more space for whatever free space we provide. Anyway this problem was encountered when I updated from

    Catalina 11.15 to Big Sur 11.0 (trouble moving Xcode from 12.4 (12D4e)) to 12.5

Add a Comment

Replies

Alright, so, I cleaned up my disk. Finder shows 63 GB free. "Storage" tab in "About This Mac" shows the same...


However, using QuickLook on my disk (one and only disk I got with computer) shows 17 GB free only?!?


df -h
also shows really strange output:


Filesystem      Size   Used  Avail Capacity iused               ifree %iused  Mounted on
/dev/disk1s1   113Gi   97Gi   13Gi    89% 1427126 9223372036853348681    0%   /
devfs          332Ki  332Ki    0Bi   100%    1150                   0  100%   /dev
/dev/disk1s4   113Gi  2.0Gi   13Gi    14%       2 9223372036854775805    0%   /private/var/vm
map -hosts       0Bi    0Bi    0Bi   100%       0                   0  100%   /net
map auto_home    0Bi    0Bi    0Bi   100%       0                   0  100%   /home


I am not using and never used Time Machine backups on this computer, there are no "purple bands" in "Storage" window, I tried to reindex the volume (by adding and removing a folder in Spotlight settings), my trash is completely empty, I tried to reboot couple of times...


Why is this happening??

Might want to ask support about the store, but in the mean time, try downloading from here, instead: https://developer.apple.com/download/more/

Post not yet marked as solved Up vote reply of KMT Down vote reply of KMT

Free space on disk, and available space on a working partition/Volume via the Finder are not the same thing.


Assuming your macOS is modern, your single 'disk'/SSD has more than one partition/Volume.


You should only be concerned with what the Finder says on your boot partition. Don't be chasing ghosts, otherwise.


Did you manually download and install Xcode 10.1.xip from here, yet?

  • I did that but getting the same error i have around 36gb free space

Add a Comment

I'm having the same problem though i have 17 GB free space. Looks like xcode needs more free space.

17 GB free is not nearly enough.


  • The OS needs 8~12 GB free just run, at least
  • The download is about 5 GB
  • You need around 7 GB or more to put the unpacked files during the install
  • You need around 7 GB or more for the installed files

- all at the same time...that's around 30 GB. Minimum.


Even with 50 GB free (don't forget to empty the trash), you're working yourself into a corner fast. Sounds like it's time for you to buy a bigger boot drive. Figure out how much you need, then double it, then double it again.


Good luck.

Hi, I am having the same issue. I recently upgraded to MacOS Mojave from MacOS Sierra and the Xcode application stopped launching upong upgradation. I therefore removed it using 'sudo rm -r /Applications/Xcode.app'. However when I am trying to reinstall it, it is showing not enough disk space error even though I have 30GB of disk space available.


Were you able to solve your issue after you cleaned up your disk to increase the disk space?


Thank You.

😟 Same problem for me.
I got 91GB freespace

Running latest 10.14.4


Worst thing is that I can't find xcode 10.2 from https://developer.apple.com/download/more/ currently.

Same here - I have 250GB free space


EDIT: solved it by removing a lot of purged disk space via daisydisk.

  • This worked for me! Apparently I had time machine partitioning my drives without really knowing. I am a total noob when it comes to macs as this is my first mac book. Anyway, the file system is VERY different than windows and I had no idea that I really only had 25GB of free space left and was only really using 60 GB.. the rest was all time machine back ups. This was what was preventing me from downloading xcode. I tried daisy chain and it is so easy to use and not only is my mac much faster but I am also after 3 days of trying to download xcode.

  • This worked for me but I had to clear out more memory despite having 30GB memory (macOS Monterey).

    First I followed the step in (https://www.jackenhack.com) The macOS system will clearcut purgeable memory. This cleared out at least 10GB.

    Then I used Daisydisk free trial, and run terminal commands to delete big files. Always research what's safe to delete. My documents folder went form 16.5GB to 2GB.

    I have 58GB free now and was able to download Xcode from Appstore successfully.

Add a Comment

Solved too by force purge purgeable space. Follow this method:

https://www.jackenhack.com/mac-os-remove-purgeable-high-sierra/


I would say this is appstore bug.

  • Thx, it worked for me!

Add a Comment

This morning my MacBook Pro (13-inch, 2017, Two Thunderbolt 3 ports) with 250GB ssd and 103GB free space running the latest MacOS Mojave 10.14.6 prompted me that there was not enough space available to upgrade Xcode to the lateast v.11...

I also have the same problem. I enrol Apple Beta program and start downloading of Mac OS Catalina. And after that xcode start to downloading from AppStore. (P.S i don't install new MacOS itself)

It strange, but it works!

Same issue here. Deleted Xcode and installed it. That worked.

Hi, i had the same problem. I restarted my computer and that worked

The same thing happens to me and I can't solve it, I tried to create an app for my website https://espias.eu/camaras-espias/, but when I try to install XCode I get the same problem.


I would appreciate the answers.

hi

i had the same issue. But i did install xcode 11.3 successfully by following this


Step 1 - Logout from your App store accound

Step 2 - Restart your MAC

Step 3 - Sign in back to your App store and then download xcode.


Thanks

  • Thank you! 🙌🏻 I tried EVERYTHING else and this was the solution that worked. MacOS 12.2.1 and Xcode 13.3.1.

  • Not working.

  • Worked for me! Thank you! 🙌🏼

Add a Comment