Catalina install freezes on boot

Catalina hung for over an hour when finishing the install.

The machine installed on the black screen with the Apple logo no problem, then rebooted to the login screen where a progress bar was then shown. The bar got to approximately 90% complete and would not continue. I hard rebooted the machine and booted into verbose mode (CMD+V) to see the output.

It repeatedly prints out:

Notice - new kext, v15.0.3 matches prelinked kext but can't determine if executables are the same (no UUIDs).
Interface link is not up, do not pull packets yet

Interface link is not up, do not pull packets yet

Interface link is not up, do not pull packets yet

Interface link is not up, do not pull packets yet

Interface link is not up, do not pull packets yet

kextd stall[0], (60s): `GFX0`, `IGPU`, `GPUC`, `IOResources`

considerRebuildOfPrelinkedKernel triggered rebuild

I have tried moving out of the WiFi area to see if that would help but it didn't.

I was able to reboot into Safe Mode, where I deleted all my LaunchAgents and LaunchDaemons. Rebooting did nothing. Does anybody have any idea how I can resolve this?




I hope they fix this quickly because I am having the same issue here!

Exactly the same on my MacBook Pro. Luckily you can do nearly everything on safe mode. Was a bit a hoffe and search to find where to upgrade my iPhone to 6

I got into safe mode as well. I would go to feedback assistant so you can send Apple your diagnostic information. That's what I did and hopefully that may help them in fixing this issue.

Hello Jack,

I just had the same issue after rebooting Catalina, the bar at approximately 90% for a long time, never reaching the login screen.

Rebooting was working perfectly since installed, but after about 6 hours using the system I rebooted it again and my system behavior was exactly like yours.

I dedicated about 2 hours investigating it and I found the cause and how to solve it.

The problem was caused by time machine "local snapshots".

Local snapshots are backups created on the local disk, even if you have an external disk connected and dedicated to time machine.

I have an external disk that always worked well, and it was working very well today on Catalina.

But Catalina creates various local snapshots also on the root disk (and there is no way to disable localsnapshots like on previous MacOS versions which was possible to disable just the localsnaps)

What technically happens when the progressbar stucks on 90% forever is that the system is somehow verifying those local snapshots, and it take hours, so we thing the system is frozen there just before the login screen appears. But it is not frozen, it is analysing data on disk.

This is bad, I agree, and is a Bug. But bugs are expected.. this is a developer version. Bugs are welcome somehow 🙂

How to solve it:

  • Boot into safe mode [by holding Shift just after the boot bell sound],
  • login to your user,
  • open a Terminal window

Once on the terminal window prompt, lets check if this is the cause:

type the command below to list all local snapshots

tmutil listlocalsnapshotdates

You should get a result like this:

Snapshot dates for all disks:








In my case I had 7 local snapshots as seen above, and we must delete them to fix Catalina (I decided to delete them all, because I have my backups already on my always connected external disk used by Time Machine)

The syntax to delete is:

tmutil deletelocalsnapshots <snapshot>

One by one:

tmutil deletelocalsnapshots 2019-06-04-082639

tmutil deletelocalsnapshots 2019-06-04-113651

tmutil deletelocalsnapshots 2019-06-04-135729

and so on....

After deleting them, run again the first command [to list the snaps] , just to be sure there will be no results.

Reboot the system.

Catalina will boot fast and you will be able to login and use it normally.

If you have any questions, feel free to ask.

  • this did not work for me sadly

Add a Comment

I guess I have the same problem. I can only boot in safe mode. And I cannot enter in my account. If I do, something crashes, my background pic is shown, then a black screen, then my pic again.. endlessly. And it looks as if there are no fonts, all menus are there, but without text.

Of course you can't downgrade and also you can't reinstall 10.15...

Is there somewhere a stand alone installer for 10.15?

Same issue here. I get as far as the boot logo/progress bar/spinning wheel but it eventually freezes. I was able to boot into safe mode, but it was unbelievably slow and eventually gets to the point where I can move the cursor but not click on anything.

I'm also able to SSH to it, so thankfully I will be able to install software upgrades once Apple hopefully fixes this issue.

EDIT: I tried to submit an official bug report, but I keep getting "There was an error trying to submit your feedback. Please try again later." so I guess not...

How were you able to get it into safe mode. My computer won’t even enter into safe mode

Okay, figured out the problem is one of my 3rd party kexts. I temporarily relocated the contents of /Library/Extensions and now my Macbook will boot just fine.

mkdir ~/Extensions-Backup && sudo mv /Library/Extensions/* ~/Extensions-Backup/
  • ***** Boom - thank you!!! I had been struggling on this for the past 5-6 hours and following above instructions was able to get past the frozen Mojave upgrade. Thank you very much, sending good vibes your way!! :-)

Add a Comment

yep! That did the trick, even the user that wouldn't load in safe mode works now.

I was suspecting kexts, too, just didn't know where to look for them on this slow computer.


Thanks for the tip. In my instance, the culprit was AVVideoCard.kext. Removing that did the trick. I think that was left behind from an old install of 'Air Display'

This solution worked perfectly for me after a couple of hours of watching a black screen with apple logo. Many thanks!

for how many hours you watch the black screen with the apple logo?

Fixed my issue as well

Jack, did you solve your problem?

Yesterday I posted here a big writeup on how to solve it because I had the same situation as you, and the cause is different from the replies above. And also the solution is different.

It affetcs everyone who is using Time Machine, and the progress bar stops at 90% for hours.

But because I posted a BIG writeup full os details, its here for moderation and people cannot read it yet.

Are you sill having that issue?

Umm, makes sense...

Yesterday reported (and sent a bug to Apple) that AppleKextExcludeList is missing on this first beta. I guess that's why you're seeing this message on boot, since the apple driver is unable to check the kexts against the list..., because it doesn't exist!!

Posted here yesterday