Xcode 10.3 - No Simulators Available

Xcode 10.3 (10G8) (App Store)

Mojave 10.14.5 (18F132)

Problem: No Simulators appear in the active Scheme popup menu.

The Simulators were available and working in Xcode 10.2.1

The Download Simulators window informs me that iOS 10.3.1 is the current Simulator and that the latest iOS Simulator available for download is iOS 12.2.

If I attempt to perform Add Additional Simulator (e.g. iPhone XR), I get the error:

Invalid runtime: com.apple.CoreSimulator.SimRuntime.iOS-12-4

I have reinstalled Xcode 10.2.1 alongside Xcode 10.3.

When using the newly reinstalled Xcode 10.2.1. the Simulators are are available, and the chosen Simulator (iPhone XR - 12.2) works.

$ xcrun simctl list runtimes

== Runtimes ==

iOS 9.3 (9.3 - 13E233) - com.apple.CoreSimulator.SimRuntime.iOS-9-3

iOS 10.3 (10.3.1 - 14E8301) - com.apple.CoreSimulator.SimRuntime.iOS-10-3

iOS 12.4 (12.4 - 16G73) - com.apple.CoreSimulator.SimRuntime.iOS-12-4

tvOS 12.4 (12.4 - 16M567) - com.apple.CoreSimulator.SimRuntime.tvOS-12-4

watchOS 5.3 (5.3 - 16U567) - com.apple.CoreSimulator.SimRuntime.watchOS-5-3

Any suggestions are appreciated.

Accepted Reply

I had the same issue. Rebooting my computer solved it.


Getting the same problem. My previously configured simulators have disappeared, and I'm unable to create new ones.

Same here. Tried using fastlane to regenerate simulators and i get a ton of errors like "Invalid runtime: com.apple.CoreSimulator.SimRuntime.iOS-12-4"

I think XCode 10.3 needs to be repackaged and re-released.

I had the same issue. Rebooting my computer solved it.

Restart my computer fix this problem...

Restart computer fix this problem +1

Thanks. Restarting did the trick. Cheers.

Rebooting did not work for me. Here's what did, which worked:

- **** XCode.app from Applications

- **** ~/Library/Developer (warning, can contain useful things like Archives)

- restart

- reinstall xcode

im getting a error on 10.3 as well. but mines is saying "an internal error has occured editing functionality may be limited"

i hace cleaned the project and reporteded the bug but i cant see anything i worked on in my storyboard

Thanks, it solved it for me too

Though feeling as we're turning into Windows OS 😟

Restarting my computer fixed the issue.

after 6 hours of pulling my hair out -- restarting my computer did the trick... thx all for sharing... absolute nightmare from Apple

So, we were on the last day of our sprint and had tons of stuff to do, and this update (which happened overnight) took 1h of my time (between trying to reinstall simulators, and then reinstalling Xcode), until I decided to search for recent posts regarding this issue, found this and fixed it. It happened to all of my coworkers who use Macs as well.

If an update needs rebooting, you either reboot it when it's idle, or prompt the user to do so. Both of these would be a million times better than letting the user figure it out eventually.

Restart computer fix this problem + 10086.

(fix meiyou moniqi,fix IBCocoaTouchPlatformToolDescription)

Restart fixed it for me.

Yeah reboot!

It will work in simulator and on devices.