syspolicyd high cpu usage

Hi all,

For the last couple of betas of Catalina I've noticed that the process "syspolicyd" chews through CPU usage without ever dropping. The process seems to start up by itself and then consume a huge amount of CPU (often 98%) causing my Macbook Pro to spin up fans to try and cool it.

It doesn't seem to stop by itself so I've resorted to killing the process manually but I wondered if there's a known issue or fix for this?

The same problem, now, with the version 10.15.6 (19G73)
10.15.6, Same problem, seems we have just traded one issue for another. Hope they get this resolved quickly as my laptop runs hot as it is before this issue.
the same here MCP 15 2019
Same PROBLEM when I run xcode on test iphone CPU uses more than 300+% CPU NOT FIXES, Battery is gets lower fast. temp is high, fans are loud.
Same problem!
Ver: 11.0.1 (20B29)
I have the same problem with big sur Ver: 11.2.2

Anyone solved this?

MacBook Pro mid 2015

Same problem!!! Ver: 11.4 Big Sur

Same 11.2.3 (20D91) on MacBook Pro 2019 - no fix for this yet?

Same issue, macOS big sur 11.4, mbp 15", 2018

Same here. Just upgraded to Big Sur 11.4. mbp 15", 2018. Ok b4 upgrade. Chronically high CPU from syspolicyd ever since.

Afraid my CPU might melt down

Same PROBLEM 400% cpu usage!


You could check the lsof (list open files) command, like sudo lsof -c syspolicyd to see what files are touched by it.

Same here on Monterey 12.3.1

I once believed owning a mac provides you a smooth as butter experience since there are no unknown random processes using much of your cpu as in windows system. But I was so wrong. These random processes like syspolicyd, diagnosticd are consuming too much CPU. I thought that I have installed many unwanted softwares so I have now formatted the system expecting to have a nice experience with my macbook but the problem still exists.

Apple was once fined for slowing down older phones. Now I believe they are messing up with macs as well. My system (MBP 2017) has random processes up and running consuming too much cpu and leading to fans running on full rpm. I thought this would all disappear after completely formatting the system. But, Naah!! The issue still exists.

The same here: macOS 12.6.5 (21G531)

Same issue here on 12.6.8

Richard Stallman has always been right.

Found the process. It's Acrobat reader. Simply quit and you'll no longer have the syspolicyd or kernel task using 200% CPU or more .

syspolicyd high cpu usage