macOS Big Sur breaks Razer peripherals

For whatever reason, my Razer Huntsman keyboard does work for the most part but none of the audio controls do anything on the keyboard. In addition, I've tried two different razer mice and neither work at all. Everything worked perfectly before the beta.
Post not yet marked as solved Up vote post of Sashimi Down vote post of Sashimi
26k views

Answers

Try to uninstall the app and install it from scratch. I do have a pair of "legacy" Razer devices (Naga Chroma and Tartarus), both "works" (I have to unplug them and plug them back in for the app to identify the hardware and go past a "Please connect a Razer device" message/apply the custom key bindings). I'm currently running their 1.88 code (although 1.87 is the latest Synapse 2.0 you can download from the website, it does update itself after installed).

Still, you might be better looking at replacement hardware: Razer drivers are pretty ancient, not updated since Mojave and already showing messages from Apple about them going to get broken on future updates since Catalina came out last year. Which is sad; I do enjoy having a ton of extra buttons for macros.
“Hi, was also having this issue and found a fix. I have a 2019 MBP 16” and noticed that trackpad, internal keyboard, Touch Bar, USB mouse, etc. all stopped working. What fixed it for me was to take all extensions in the /Library/Extensions folder and delete them from that directory and place them on my desktop. I then restarted my computer and once it was done I found that everything started working once again. After this, I placed all of the kext extensions back into the original directory and restarted. Even after placing them all back, everything works as it should :)”

Original post from /u/theolaw on Reddit.

Karabiner Elements works for me to replace the Razer Synapse software. I've configured it to map the Naga mouse "1" to "keypad_1" etc. It doesn't let you change the colours or any of the other settings (that I can see) but at least your extra buttons can behave.
I had the same problem with my Razer Tartarus game pad. Razer Synapse was unable to detect my device.
I've uninstalled Razer Synapse, and I've installed Karabiner Elements instead. It works like a charm. It's quite easy to configure.

So for anyone updating to Big Sur and using a Razer Synapse 2.0 v1.88.20.

After 4 hrs I've got it working.
After update to Big Sur Synapse was loading for me but was not detecting devices.

manually running
Code Block language
sudo kextload /Library/Extensions/RazerHid.kext

will error suggesting to Approve extension via System Preferences.

3rd Party extension popup and Allow never showed up in a pane.

After digging around and looking up Razer TEAMID R2H967U7J8 I was able to manually adjust security settings:
  • Boot into Recovery Mode

  • Click the Utilities menu and select Terminal.

  • Execute the following command:

Code Block language
/usr/sbin/spctl kext-consent add R2H967U7J8
  • Verify that team got added

Code Block language
/usr/sbin/spctl kext-consent list

Should output something like:
Allowed Team Identifiers:
R2H967U7J8
  • Close the Terminal app and restart


After this I was able to execute
Code Block language
sudo kextload /Library/Extensions/RazerHid.kext

Got popup and Allow button in System Preferences.
Allowed extension and restarted.

Got my Naga Epic Chroma back in Synapse after reconnecting it.

avaddon! your fix works! MY ORNATA LIVES!
My Razer Deathadder lags my whole computer WHEN moving it, both on my Mac Mini & my MacBook Air.
I cannot install Synapse just to see if it'll make a difference. I tried what avaddon said, but no avail.

It was working on Catalina.

Video: streamable.com/4gzafu
avaddon's solution works! Thanks a lot!
You can use Karabiner to replace synapse. It works like a charm with my orbweaver
It works well, thank you very much avaddon :)
I’m using the terminal in recovery mode and inputting the command:

/usr/sbin/spctl kext-consent add R2H967U7J8

And I get the following output:
/usr/sbin/spctl: No such file or directory

Am I doing something wrong? Trying to get my synapse working for my razer naga chroma mouse, and having the same issue with it not detecting it.


Do your Razer mice work on Big Sur? It's slowing my whole computer when moving it around. Dock is unusable!
Its not working for me so far....I see:
Allowed Team Identifiers:

R2H987U7J8

iMac-van-Pieter:~ pieter$ 

But then with the other command I see...
Executing: /usr/bin/kmutil load -p /Library/Extensions/RazerHid.kext

Extension with identifiers com.razer.common.razerhid not approved to load. Please approve using System Preferences.
......so frustrating..... what did I do wrong?



avaddon's solution works perfectly! Thank you!
Managed to get it working with avaddon's solution as well. Though my popup didn't have allow, it just had an Okay and after I pressed it, nothing changed.

Now I get:

"Extension with identifiers com.razer.common.razerhid not approved to load. Please approve using System Preferences."