Big Sur Beta 7 breaks SMB?

After the upgrade from Beta 6 to Beta 7 I am not able to connect to any smb-shares any more. I tried it with a Windows Server, Synology DriveStation and a Debian implementation. I'm directly getting the message Error with connection.

46 Replies

Unredacting the logs reveals the issue, insufficient permissions to load the kernel extension. Just run this (once):
sudo kextload /System/Library/Extensions/smbfs.kext

Edit: filed as FB8628919
I have the same issue, but I've noticed that happens with servers with Windows Server 2008. With more recent versions it works.
I am experiencing the same issue (11.0.1) and the proposed solution doesn't work for me.
My SMB-not-connecting issue got fixed with the latest beta: 11.0 Beta (20A5395g) (the same issue that was previously fixed with the command-line string that another user posted)
worked for me thanks !
Thanks!!!
It seemed that it was fixed on beta 7.
Thanks! Worked with sudo kextload /System/Library/Extensions/smbfs.kext


Adding this AppleScript to your Login Items will fix it at login until Apple fixes it:

Code Block
do shell script "kextload /System/Library/Extensions/smbfs.kext" user name “name” password “pass” with administrator privileges


Thanks for the workaround..... As of Beta 7, the bug still exists, and it's boot to boot.
Amazing, given we're only on Beta 6 and 7 hasn't been released?
Thanks. This worked for me!
It does work for me as well, thank you!
Thank you, this fix worked for me
This saved me big time. Thanks y'all!