iOS 14 Spotlight Issues

Ever since the first iOS 14 beta, my Spotlight search results have been missing. This continues with beta 8.

When I search I get suggested websites, Siri knowledge, and dictionary, but no app name results, and no data results (ie I can't search my email or contacts).

I've tried a clean install to no avail.

Any ideas on how to get spotlight reindexed or rebooted?
Post not yet marked as solved Up vote post of themexican Down vote post of themexican
5.2k views

Answers

Same here, also in released version.
Anyone with same issue or a solution?
Same here applications and contacts in spotlight are missing in iOS 14 release.

So, the recover (clean install) didn’t help to you ?
There are so many changes in iOS 14 regarding spotlight and apps library.

Need to recover or rebuild index as I see.
After google something I know that this problem was well known before in iOS 14 betas.

I have a lot of apps.
Hello,

I had the same issue for one week, I tried and tested all the workarounds and fixes on the internet, nothing worked!

The only fix worked with me is the following :

1- Update to the official iOS14
2- Reset your iOS through (Reset All Settings) option.
3- Now it should work fine.

You need to re configure your iPhone/iPad to your favorites settings after that.
Same issue here. No Apps are shown, no contacts are shown.
Tried backup/restore in iTunes and iCloud. Both did not work.
I also have lots of apps (1052) installed.
Resetting the settings did also not help to fix it.
Hello date : 03.11.2020 (November) - 14.2 ios
Same issue here , before ios 14 it worked correctly. But now ... when i type something it starts working , search apps and etc . But 5-10 minutes after using/restart phone it stops working. When i open spotlight there are no recently used apps no contacts no actions.
iOS 14.2, iPhone XR. Apple, how do I fix the problem?
Hi everyone

I am having exact problem with Siri Spotlight/app suggestions partially not working. Started on iPhone 11 Pro Max on iOS 14 beta and now it is still present in new iPhone 12 pro max on official iOS 14 release.

they will work for some time time and then I swipe down and nothing shows just a search bar. If I type in it all magically appears again and will work fine for an unspecified time. Then to crash again.

did everything, all kinds of resets and even restore via cable and mac, it will just not work.

Apple support didn’t help much.

it seems to work fine if I have nothing installed beside Apple apps. When I install at least one or two third party apps it starts to act funny with the spotlight page.

so anyone has the solution for this yet?
IPhone 12 Pro Max - IOS 14.2.1

The issue is still here. Did anyone found a fix yet?
I had the same issue but I fixed it today by doing a cold reboot (aka a hard restart) on my iphone 11 pro max.
To do this press the volume up & let go then press the volume down & let go then hold the lock button in until the screen goes black. Wait for the phone to restart.
Hi Everyone,

I have the same issue as well. I have two iPhones, one is iPhone 12 and the other is XS.

When scroll down to search for certain things XS can perform the result immediately but the 12 shows a blank page.

I tried cold reboot, re-install from backup, re-install as a new phone. It can only be fixed in a couple of days. After maybe 5 to 7 days, it back to the same blank page.

Does anyone have the same issue?
Problem persistent even in iOS 14.4
Even after clean install Siri suggestions don't show up every time!

Apple, please fix it!!
Ah, I don't know why I don't learn! ALWAYS Google "bugs" on next upgrade before you do it...

It's just that red dot irritates this OCD guy too much.

But to not have a search function just seems completely idiotic! IOS14.4 now, and I have a lot of apps - and no search functionality - come on Apple, please sort out asap!
I went to the apple store last week, they change a new phone for me and it works perfectly fine for couple of weeks. But today, it comes back again...........
I have problem with siri suggestions on home screen. It show 2 times in 10 attempts
iOS 14.4
Shshseuajabajassbdjsj
  • Same problem, very frustrating. Hoping for a real fix.

Add a Comment