Mac OS Big Sur Preference error when trying to launch security preferences to Allow System Extension or Kernel extension

Hello,

We are seeing an issue with security preferences that it is has an error when trying launch security preferences to allow system extension or kext .

We have tried deleting these plists
~/Library/Preferences/com.apple.systempreferences*
~/Library/Preferences/ByHost/com.apple.systempreferences*
~/Library/Caches/com.apple.systempreferences*
But didn't help.

This is happening on beta7 on Intel systems and also on Developer Transition Kit too.

Solved Answer

Looks like it's fixed in Beta 9! Google Drive File Stream installs and Security & Privacy doesn't crash allowing me to allow it.

25 Replies

I ran into below error today with Big Sur (20A5364e) build after fresh installation.

Preferences Error
"There was an error in Security & Privacy preferences"


I am having the same issue. Tried a lot of different things, including a fresh install over my existing. Have you found a fix?
Seems to happen after I restore my Time Machine.
Same issue happens to me
Regardless of the issue, you should use defaults delete to remove preferences from the current user, since the cfprefsd process will keep an in-memory copy of the data.
I deleted the following files from the / Library and ~ / Library folders:

com.apple.security.plist
and
preferences.plist

then I was able to open the security preferences again.
I'm not sure if this works for everyone or if it was just a coincidence for me, but it would be worth a try.
I have the same error. I can't find
com.apple.security.plist
and
preferences.plist
in my Library
Any fix from Apple for this issue?
Mac OS 11 beta7 (20A5374g) also has the issue
Any solution that works? I removed the preferences files in /Library and ~/Library and it did not work.....

Thanks
For me, it seems tied to Gatekeeper. If an application or kernel extension needs to be allowed, it often seems to break and give that Security & Privacy error every time I attempt to go in. Clearing out the preferences files (via defaults delete or otherwise) mentioned by others doesn't help -- nor does rebooting or logging in as a different user -- but leaving it alone long enough for Gatekeeper to time out on those allow requests seems to resolve it. Unfortunately, that means you can't open any apps that are prompting for it or add any kexts, it seems.
I have gotten some to be allowed because it doesn't always seem to happen. Hoping they fully fix it in the next beta.
mjg415, well it is not 'fixed' in beta 8 (just released)...

I think mine has to do with a kext install as part of VMWare Fusion 12 - tools (I tried installing it in a VM on my faster machine rather than on my slower laptop which I currently have the beta on)... the install worked, but because of the lack of tools the resolution and size of the screen ... is very very bad... oh well, will have to wait for GM release to install on this machine I guess -- back to my laptop for beta.
I tested with Beta 8 and the issue is still there. This is the crash stack trace:

dyld3 mode
Crashing on exception: The window has been marked as needing another Layout Window pass, but it has already had more Layout Window passes than there are views in the window.
<NSWindow: 0x7fcf586a6400> 0xffffffff (-1) {{173, 220}, {480, 348}} Window en

Application Specific Backtrace 1:
0 CoreFoundation 0x00007fff205f9bdf _exceptionPreprocess + 242
1 libobjc.A.dylib 0x00007fff20219469 objc
exceptionthrow + 48
2 CoreFoundation 0x00007fff205f9a43 +[NSException raise:format:] + 189
3 AppKit 0x00007fff230429c3 -[NSWindow(NSDisplayCycle)
postWindowNeedsLayoutUnlessPostingDisabled] + 1707

In my experience it breaks with both VMWare tools and with Google Drive File Stream. I tried upgrading a physical machine from Catalina that had GDFS installed and I got into a reboot loop upon boot. After about 4 tries I got a message about a kernel panic keeping the system from starting and it said it disabled it. The system then did start but GDFS kept crashing as well as the Security & Privacy preferences window as reported here. After uninstalling GDFS I can open S&P Preferences.

On a fresh VM, after attempting VMWare tools install, I had the preference page crash. On another fresh VM, GDFS install induced the same behavior as the physical machine upgrade above.

I see the same issue reported on this site as a new Beta 7 bug: mrmacintosh.com/category/11-0-big-sur-beta/

Haven't tried Beta 8 but it's discouraging that it has been reported to not have fixed the bug.

We've seen this a bunch of times as well. Usually removing any staged System Extensions and rebooting will fix it, but it seems to happen randomly.
I've had the same problem since this morning, anyone have a fix?