Big Sur Breaks Airpods Connecting to Macbook

So after updating to Big Sur, my airpods won't connect to my Macbook. It let's me connect but after 5-10 seconds it just disconnects. (No audio can play during this time either). I've tried removing the airpods from my iCloud devices a couple ways but it didn't seem to make a difference. Please help!
Post not yet marked as solved Up vote post of nemomeister Down vote post of nemomeister
12k views

Answers

Same here. I've reset the BT module and update Bigsur 11.0 Beta (20A5384c) - doesn't change a thing :/
  • I have macbook air 2015 big sur 11.4. I've followed this instruction and it fixed it for me: https://appleinsider.com/articles/21/01/05/how-to-reset-bluetooth-on-macos-big-sur

    Hold down the Shift and Option keys, then click on the Bluetooth icon in the menubar Choose Reset the Bluetooth module from long menu that appears Click OK to confirm Restart your Mac

    and thats it. work perfectly.

  • Does't work. AirPods Pro gets identified in the available blueetooth devices and the "Connect" button is enabled. After clicking the connect button, the spinning wheel just does what it does best - spin. No trace of what's happening.

Add a Comment
Unfortunately the problem still exists with Big Sur 20A5395g on my MacBook Pro (13-inch, 2016), @nemomeister what mac do you use?
Same problem with new update of Big Sur 20A5395g. Please find somebody to fix it!!!
I could resolve this issue finally with removing additional audio plugins in the folder /Library/Audio/Plug-Ins.

I don’t know which of the following plugins caused the problem:
  • 1. /Library/Audio/Plug-Ins/Components/AppleAES3Audio.component

  • 2. /Library/Audio/Plug-Ins/HAL/DVCPROHDAudio.plugin

  • 3. /Library/Audio/Plug-Ins/HAL/InstantOn.driver (com.rogueamoeba.instanton-agent)


  • This worked for me too, thank you so much!! I've been browsing for ages for a fix! Fixed both my Airpods and my Sony WH-1000XM3 (Y)

Add a Comment
Mine won't even connect to my MacBook. Running Big Sur 11.0 20A5395g.
This fixed it for me:

"I could resolve this issue finally with removing additional audio plugins in the folder /Library/Audio/Plug-Ins."

I just deleted everything in there, restarted and hey presto. Airpods and Jaybirds finally working perfectly and holding connection with Big Sur.
  • This worked!

    After deleting all the 3 folders in the plugin directory (I didn't have a HAL folder as BlazingArrow mentioned), AirPods connected immediately.

    Running 11.4 but the issue carried over from 11.3.1

Add a Comment
I have some problems - Big Sur 11.0.1 (20B28) - not only Airpods Pro but any Bluetooth headsets or headphones on my iMacPro still connect / disconnects after about 3-5 second.
this problem is in release version of Big Sur! I see the problem with AirPods Pro and with other my bluetooth headset
Post not yet marked as solved Up vote reply of urix Down vote reply of urix
Problem persisted in the released version!!! Not really connecting my airpod pro
Same issue apple is breaking things in new updates really too much Bluetooth is basic feature which should not break on new updates
You need to reset your bluetooth. I followed this suggestion:
  1. Press Shift-Option and click the Bluetooth icon in the menu bar.

  2. Select Debug.

  3. Click “Reset the Bluetooth module.”

  4. Press "Ok" to continue.

  5. Restart computer

This reconnected my Airpods and bluetooth on my MacBook Air 2020. How sad I had to go to some random blogger's website to fix a developer's mistake. This whole process used up about one of hour of my time. Thanks Apple.

  • I'm so grateful for your solution!

    By the way, had an issue on Big Sur 11.4. I was moving from Macbook Pro early 2015 to Macbook Pro 2019. My AirPods Pro wouldn't connect to this mac, while there is no issue on the other devices. I was resetting them, changing their name, forgetting... Nothing worked. Resetted the Bluetooth module, restarted the mac and there they are - connected. I guess, that might be because of the same macs names, strange...

    Once again, thank you very much!

  • I applied this solution which works for me

Add a Comment
I called Apple today 11/23 and they take a long time too to figure it out what's happening, and the soluction was remove a plugin from Audio Seetings at Library.

Code Block
/Library/Audio/Plug-Ins/HAL


So now my Airpod's Pro is working property well.
Just remove this folder to trash and its done.
Reseting Blutooth as mentioned by CVPDX followed by a restart was the solution for my macbook air 2020 (Big Sur 11.0.1)
Hi!

Can someone please help? I removed audio plug ins, it still doesn't connect.

Thanks!
I did the reset and it didn't work so i deleted everything in that audio folder. it worked. phone calls shared form my iPhone picked up on my mac are fixed. thank you.