Netbeans 12 and Big Sur

Has anyone test latest version of Netbeans with Big Sur?. It is running fine?
Thanks!!
Post not yet marked as solved Up vote post of JuanMiguel Down vote post of JuanMiguel
5.5k views

Answers

Hi!

For me, it is running "quite" fine.
It's possible to use it in its most features. But, once you open some dialogs such as Project Preferences or Plugins, it freezes and start blinking... Can't figure it out what is goin on...
Stop working for me, since Big Sur was installed.
Not found any solution.
I was installed JDK
Open Terminal and check de javahome with command: /usr/libexec/javahome
The result is: /Library/Java/JavaVirtualMachines/jdk-14.0.2.jdk/Contents/Home

I open /Applications/NetBeans/Apache NetBeans 12.1.app/Contents/Resources/NetBeans/netbeans/etc/netbeans.conf
I copy the last directory showing in terminal and past in netbeans.conf in property netbeansjdkhome=

Like this
netbeans
jdkhome="/Library/Java/JavaVirtualMachines/jdk-14.0.2.jdk/Contents/Home"

It's fine here now

Same here, dialogs block and NetBeans freezes. This *is* a problem
Hi,

I had the same issue but as mentioned by @remenechelli, so I did following things

Code Block
$ /usr/libexec/java_home
/Library/Java/JavaVirtualMachines/jdk-14.0.2.jdk/Contents/Home
$ nano /Applications/NetBeans/Apache\ NetBeans\ 12.1.app/Contents/Resources/NetBeans/netbeans/etc/netbeans.conf


then uncommented following line
Code Block
#netbeans_jdkhome="/path/to/jdk"

and replaced it with the above output
Code Block
netbeans_jdkhome="/Library/Java/JavaVirtualMachines/jdk-14.0.2.jdk/Contents/Home"


Please Note: I am using NetBeans 12.1 if someone is using diff version then please the path accordingly.

That's it, Hope it helps!
Hi, I successfully launch netbeans 12.1 in big sur but the problem now is that it does not have access to files or folders, when trying to open a project it just does not show. I tried give full disk access but didn't work either. Has anyone an idea of how to fix this?
Mine isn't opening at all and I need to complete a project
Does anyone know how to help?

I am running on 12.1, but it breaks when a dialog is opened. As said before, it blinks and the IDE is stuck.
This is also happening to all Netbeans-based programs: Oracle Modeller for instance.
I have tried with all the JDKs I could find:

AdoptOpenJDK versions 8, 11, and 15 (either using OpenJFX and J9).
Amazon Correto versions 8 and 15.
OpenJDK version 8, 14 and 15.
Zulu JDKFX 8 and 15.

Same problem running on all of them.

Help !!!!

For all that have issues with Java Netbeans-based UI applications (esp. Netbeans, Oracle Data Modeller, etc).
Change "Prefer Tabs" option to Never, and all will work with Big Sur.

Settings -> General -> Prefer tabs: never

Save and restart Netbeans.


For all that have issues with Java Netbeans-based UI applications (esp. Netbeans, Oracle Data Modeller, etc).
Change "Prefer Tabs" option to Never, and all will work with Big Sur.

Settings -> General -> Prefer tabs: never

Save and restart Netbeans.

  • ---This doesn't work.

The precise and correct advice is "System Preferences>General>Prefer tabs: [never] when opening documents".
At least that fixed the problem for me...
There is a problem in NetBean that it don't ask access to directory 'Documents'.
Make program with Automator which call shell script:
/Applications/NetBeans/Apache\ NetBeans\ 12.2.app/Contents/Resources/NetBeans/netbeans/bin/netbeans
for netbean 12.0
/usr/libexec/javahome
/Library/Java/JavaVirtualMachines/jdk-12.jdk/Contents/Home

sudo vi /Applications/NetBeans/Apache\ NetBeans\ 12.0.app/Contents/Resources/NetBeans/netbeans/etc/netbeans.conf
then search for netbeans
jdkhome
add the below line just below the search line or replace.
netbeans_jdkhome="/Library/Java/JavaVirtualMachines/jdk-12.jdk/Contents/Home"
Building from the response of @remenechelli, you can find this solution by googling "downloading apache netbeans 12.1" and choosing the netbeans link with the corresponding title. For some reason I cannot include a link in the post. Here is a more in depth explanation for anyone who isn't familiar with the command line

Essentially, as remenechelli described, use this command
Code Block
cd /Library/Java/JavaVirtualMachines


to go to the appropriate folder to see the JDK version folder's you have. I have one version folder, "jdk-11.0.7.jdk". Use the "cd" command to go into the version folder of the version you'd like to use (for me: cd jdk-11.0.7.jdk), then use
Code Block
cd Contents/Home


to get to your JDK version home directory. This is the directory your app launcher needs to use in order to start NetBeans. Normally it can find this on it's own, but we can explicitly tell it where to look as well, which is what we need to do to run NetBeans 12.1 on BigSur. From here you can use the "pwd" command to print the path to the home directory you are in, which will look very similar to this:
Code Block
/Library/Java/JavaVirtualMachines/jdk-11.0.7.jdk/Contents/Home


Copy this path, then use this command to get to the netbeans folder with the configuration file you need to edit.
Code Block
cd /Applications/NetBeans/Apache\ NetBeans\ 12.1.app/Contents/Resources/NetBeans/netbeans/etc


use a text editor to open the netbeans.conf file in this folder:
Code Block
vim netbeans.conf


If you are using vim (or vi), scroll to the bottom(ish) of the file where you'll see
Code Block
#netbeans_jdkhome="path_to_file"


Press the "I" key to enter Insert mode. Remove the pound symbol at the beginning and replace pathtofile with the path you copied (with double quotes around it). mine looks like this:
Code Block
netbeans_jdkhome="/Library/Java/JavaVirtualMachines/jdk-11.0.7.jdk/Contents/Home"


To exit insert mode press the "esc" key. Then to save and quit the vim/vi text editor, type ":wq". You should now be able to launch NetBeans 12.1 on BigSur.
I'm using Apache Netbeans 12.2, after updated to Big Sur 11.1 I couldn't open Netbeans anymore, however I manage to solve it with this
Code Block
netbeans_jdkhome="/Library/Java/JavaVirtualMachines/jdk-11.0.7.jdk/Contents/Home"

Thanks to Iraunak

But this part
Code Block
"jdk-11.0.7.jdk"
is the tricky part, 1st you check your java version via terminal, enter
Code Block
java -version or javac -version
then you'll get your current java version on your machine. Mine is
Code Block
1.8_111
then I put it in the string
Code Block
"/Library/Java/JavaVirtualMachines/jdk-1.8_111.jdk/Contents/Home"
Guess what? It works! Not only it solved the "can't open Netbeans after update to Big Sur" problem, it also solved my "couldn't compile SASS and create CSS/source-map" problems. AWESOME!

I hope this will help.