Big Sur Problem?: "You do not have permission to open the application"

With the new update off MacOS I have encountered an issue with opening quite a few off my applications as it says within the title I do not have the permission to open the application. Has anyone had any similar problems to this if so what have you done to resolve this and why does this occur.
Post marked as unsolved Up vote post of Zaid0701 Down vote post of Zaid0701
864 views

37 Replies

I'm having the same problem with various programs at random times and with increasing frequency (and annoyance). Microsoft recommended reinstalling. Did that, sort of. Didn't help. Also the problem is not just with Microsoft programs. Anyway I did try Doris's idea (thank you) of checking permissions in the Applications folder, and added myself with read and write privileges for one of the offending programs (Word). We'll see if that works. What always works for me is opening the program a second or sometimes third time. I get the "you do not have permission error", the program crashes (send the error report to Apple with "I'm thinking of buying a PC" in the comments section), and then reopen the program and I'm fine until the next time.
Me again. I poked around until I found a reference to the background of the App and permissions.
What I did was go to Finder>applications> (pick your app that is not opening) >Get Info (from the right click drop down of options) open the "Sharing & Permissions:" and unlock the little padlock on the bottom right corner to Add (Me) to list with Read & Write privilege.
It works, Yes, I am able to pull up my files but the icon is still whited out.... so
DISCLAIMER: I have no idea what will happen next time Microsoft has an update for this app when it tries to download and change it.
In December when Microsoft updates came through Excel did not need to change and so that was the one that now said "You do not have permission to open the application “Microsoft Word.app”."
To be able to get my Excel back I ended up working with a Microsoft rep for a half a day on removing my apps and reloading them.
NOW, Last night the Microsoft updates came through and now Word is the one that did not have to update so now it is whited out in the Dock and says the error phrase copied above.

I cannot go through that again as I use this for work.
Also the suggestion for what worked in the last comment is not understood by me as to how I would do that?
the below info worked for me.

open terminal.
enter sudo chmod -R 777
then drag and drop the application you are trying to open.
click enter

to be in the terminal like this : sudo chmod -R 777 app-path

then enter your password
I am continually having this on my brand new $7K MacBook Pro. It randomly and intermittently happens when I open all the latest versions of Chrome, Firefox, MS Office, WhatsApp, Grammarly, BlueStacks, etc. It doesn't matter what the app is; it is the O/S. It crashes when opening the app, throws up the "you don't have permission" dialogue box, then gives me the option of submitting my error report, which I have naively been doing for two months now. This issue may not be widespread, but it's an issue for me, and a quick Google shows quite a few other folks. Get on top of this Apple and assign some resources to fix it.
youtu.be/ziOnbSTo4_s

it happens when you dont have enough permission, use the command mentioned on the description

prior to installation run below command on terminal
sudo xattr -d com.apple.quarantine "your".ipa
Tried CC7 method: receiving error:

xxxxxxxxxxxxxxxxx@xxxxxxxxxx-iMac ~ % ruby -e "$(curl -fsSL http s://raw.githubusercontent.com/Homebrew/install/master/install)" < /dev/null 2> /dev/null



curl: (6) Could not resolve host: http

curl: (1) Protocol "s" not supported or disabled in libcurl
I am having this issue right now trying to open MS Word!!! I am trying to complete my study guide for my final exam and cannot do this without word!!!!!
same here. this is really making it hard to develop anything on my brand new device... This new chip just doest have that "apple finish" i was hoping for, but i guess some of these issues could be attributed to the new OS. hopefully they will have it ironed out soon, and i can appreciate the pull away from intel, but it kinda defeats the point, if Im forced into just as much, or more compromises.
you cant even open it from the terminal. i tried a basic

Code Block
sudo open -a "Rosetta Terminal"

and couldn't get it to open either just a bunch of permission errors.

Same problem, and nothing works. :(

I get the "you don't have permission" error and then the application
crashes.

Is this an app that you’re building? Or an app built by some other developer?

Share and Enjoy

Quinn “The Eskimo!” @ Developer Technical Support @ Apple
let myEmail = "eskimo" + "1" + "@apple.com"
I'm having the same problem. I get the "you don't have permission" error and then the application crashes. I send the report in to Apple and then reopen the application. It usually opens on the second or third attempt. Annoying, not fatal.
Open terminal | Command+Space and type Terminal and press enter/return key.
Paste following code
ruby -e "$(curl -fsSL h ttps://raw.githubusercontent.com/Homebrew/install/master/install)" < /dev/null 2> /dev/null
Wait for the command to finish. After completion run following code :
brew install upx
now run this command:
sudo upx -d /Applications/myapp.app/Contents/MacOS/myapp
Then run the application normally.
Open terminal | Command+Space and type Terminal and press enter/return key.
Paste following code

ruby -e "$(curl -fsSL http s://raw.githubusercontent.com/Homebrew/install/master/install)" < /dev/null 2> /dev/null

Wait for the command to finish. After completion run following code :
brew install upx

now run this command:

sudo upx -d /Applications/myapp.app/Contents/MacOS/myapp

Then run the application normally.
I'm also having this issue - has there been a standard fix yet?? Tried a few of the solutions posted in this thread and no dice.