Big Sur - external discs not mounting

Hi All,

I have a question. Just after the software upgrade from Catalina to Big Sur, my mac (Macbook Air 13-inch, Early 2015) stopped mounting any usb external discs. Doesn't matter, if it's an usb ssd card reader, usb stick, or external hdd. Does anyone have a similar problem, and any possible solution?

Same thing, but I didn't upgrade. I'm using a fresh M1 Macbook Air and it simply won't mount anything external. I can see it. It just says "not mounted"...
Same thing for me. I can plug it into my iPad without any issue, so it is definitely not a problem with the HDD. It seems like it may be a bug on 11.0.1
I have the same issue. External USB drive's that still mount in Catalina don't mount in already-running Big Sur. But if they're plugged in when Big Sur starts up, they'll mount OK.
Well, please disregard my post of a few hours ago. I shut down, started up, and now external USB drives are mounting fine. Beats me. Sorry if I'm in anyway out of line ... I'm new here so thanks in advance for slack.
I have similar issues with external USB Flash drives on Big Sur 11.0.1 (MacBook Pro (Retina, 15-inch, Mid 2015)). After plugging in USB drive I can't find it in Finder but it still can be founded under /Volumes folder. Open Finder -> Go -> Go to folder /Volumes (shortcut SHIFT + CMD + G). I hope it'll help.

Similar issue here too. When plugging in either usbC or usb3 external drives - my experience shows this is a flip of the coin whether Big Sur recognizes and mounts the drive or not. I think particularly that the exFAT partition format type has something to do with this issue. Apple's Disk Utility also has a hard time displaying what the actual formatted partition is. For instance, I took an Apple drive over to my Ubuntu Linux machine, erased the drive and repartitioned it as exFAT, removed it and plugged it into my MacBook Pro on a USB adapter and it didn't recognize the disk even after several unplugging and replugging attempts. So I rebooted. It saw the external drive, but showed it still as an Apple Journaled APFS partioned drive. That's odd I thought, so I unmounted it, removed it and plugged it back into my Ubuntu Linux machine. Lo and behold it was exFAT not APFS. What's going on with Apple's Big Sur? Hard to say, but it looks and feels like a bug.
I'm having this same issue with my Macbook Pro (2019). I've tired restarting. I've tried repairing disk but it will not mount. I'm not sure what the cause is. I have my music library on it so I don't want to format it and lose it. It's currently in Fat32. I'm unsure why Big Sur won't read it as my computer was able to read it on Catalina when I first got it.
I Have similar issue, i can see my external drives but if i transfer files to or from the external drive it starts slow and stops and in some inctents iit exit it by it self. i started seeing this after the update 11.1- Please help.
I'm also seeing this issue on an M1 MBP. I'm able to go into Disk Utility and mount my external drives from there, and I'm prompted to enter my drives encryption password. And regardless of whether I check the box to remember or not, it doesn't remember and mount them again after a reboot. Not sure of the cause here, but I'm (in my head anyway) attributing my slow Finder beachball issues to whatever is causing this issue.
I have a MacBook Pro 2019, My seagate 1TB hard drive would not mount for a while..... I have a thunderbolt -usb adaptor connected and thought it might have originally been a poor connection due to cable, after restarting my Mac in safe mode and restarting etc etc nothing appeared to work. but after leaving the device connected for approx 20mins the hard drive and all its files have appeared. just thought id share this anyway.
Macbook Pro, M1, Big Sur. Attempted to transfer file from win10 pc to mac via flash drive. Flash drive mounted but files not visible, running properties indicated files were present. Inserted other flash drives from pc, the drive mounted but files not visible.
Hi There,

I was having the same issue with my external lacie G drive not mounting but was visible in Disk utility.

I tried all sorts of things and the one that worked for me was to zap the P Ram.

I am on MacBook Pro, so restart the Mac hold shift+control+option+power button 10 secs. Once I had done this I logged back in and boom the drive mounted. I hope this helps.
I have been having the same problems not just with big sur but with Catalina also I have lost a lot of important work and file and more than one flash drive which has cost me a lot.
but what is bothering me is how Apple have not said anything, they keep bringing out new versions before making sure they are fit for use.
they need to work on the issues that are happening before moving forward.
i have spend thousands on there Products only for them to let me down and cost me more.
this is a joke.
Apple are proving to be unreliable.
I have same problems with new MacBook pro 16'. No HDD nor SSD. They worked totally fine with old MB pro 13' with Catalina.
in order to get big sur to recognize your USB drive & show it on the desktop
  • Open Disk Utility

  • Choose "Show All Devices" from the View menu

  • Select the destination drive hardware (above the existing volume)

  • Click Erase

  • Choose the "GUID" partition scheme (2nd pop-up), THEN "APFS" formatting (1st pop-up) and name appropriately

  • Click Erase

if you have files on the USB drive you should be able to open them with an app & then save them, if they are essential, before you erase.
The solution provided by CAPYDAN works like a charm for me. I have an issue with Mac.

I did exactly the same, except that I select exFAT (instead of APFS) as I need to share data among MacOS, Windows and Linux as well.
i am facing this same problem. After i updated to Big Sur, no external drive is getting recognised, not even in the volumes section. Tried a usb stick (FAT32 format), WD external HD (macos journaled), both of them are not recognised on the OS
Please help me, have tried all the solutions mentioned in the above thread.
Currently on Big Sur 11.2.1, Macpro 2017
apple is not seeing the wood for the trees here. I had the exact problem. Checkboxed everything. Still no joy. Solution lies in this: mouseover sidebar where it says locations. When u mouseover, an expandable arrow appears (really dumb for it not to always be visible). Click on it and you will see your drives if they are visible say In disk utility.
I have the same problem which came about on February 15th or so.
So far, I did not manage to solve the problem by using some of the suggestions posted above.
I have a MacBook Pro (Retina, 15-inch, Late 2013).
Processor 2 GHz Quad-Core Intel Core i7
Thanks for your help.
I have the same problem. I don't see CappyDan's instruction: Select the destination drive hardware (above the existing volume)
I also have this issue - in my case with a 2020 Macbook Air Core i7 (just pre m1)with 16GB and 1TB- I have 2 external SSDs hooked up via USB3 both of which are are formatted under APFS and used as Time Machine backup disks & supposed to alternate.

I had no issues until upgraded to Big Sur 11.2.2 48 hours neither volume mounts nor is even findable via Disk Utility (or any other method either).

I do not want to reformat and start again because of their use for restoring old document versions.

I ahem tried restarting and every other method I can think of. there is something afoot with the Big Sur External Disk recovnigitopn needs a Bug Fix!!! Or at least that someone at Apple to acknowledge it exists!
I have Big Sur OS with newest upgrade 11.2.2 and Mac Book Pro M1 2020 version. I'm using Thunderbolt 3 Dock Core and connecting external USB hard drives. They are mounted. Can be seen on Finder and there is an icon on pulpit. First aid done. Disc can be seen. Disc utility shows size of files own hard drive but is not showing the files itself. And it is for all external drives. :( On Microsoft Windows it works without any issues. Please help and do not say that I need to format a drive - it's just ****** and this is not a fix. :|
I have a similar issue. I’m using an iMac (late 2014) and recently upgraded to Big Sur. For a while Big Sur displayed the external drives in Finder, but now they are gone. I have a Seagate 4 TB External drive with a photo library on it so I do not want to reformat the drive. The external drive shows up in the disk utility but cannot be mounted. My old MacBook Air can recognize and read/write the Seagate drive fine. Need help.
So, I have a 16-inch MacBookPro that just started showing this problem. Big Sur 11.2.3 installed.

The USB drives (yes, now two of them) will no longer auto mount. However, their locations are showing in the /Volumes directory as if they are still mounted - only not really since they are (a) not connected and (b) the folder permissions are locked.

What is more interesting is that on a 15-inch MacBookPro Big Sur 11.2.3 these same exact USB drives mount correctly (as they always had). Both machines are very similarly configured as to software. Very minimal system software installed (iStats and LittleSnitch) plus the assortment of developer tools, browsers, and editors.

Also, I can mount these drives via the terminal (bash shell) via "sudo diskutil mount -mountPoint /path /dev/disk2s1"

In fact, I can even mount them onto the /Volumnes/diskname mount point (/Volumes/Andromeda) and have them work until I unmount them.

Even in Disk Utility, I can see the volumes but not mount them - even if they were mounted and I unmount them with Disk Utility and then try to mount them again. Complete failure with: "Could not mount “Andromeda”. ( error 49180.)"

I have rebooted, rebooted in safe mode, rebooted and reset the SMC, etc. I have also tried to remove the /Volumes/Andromeda mount point while the drive was not connected. Nothing lets me, even when booting into the recovery mode. Always claiming it is not permitted.

This seems like some corruption within the OS and it is somewhere written to disk such that it does not clear up and has not cleared up over the days I have been trying to recover from this.
So, I have a 13-inch MacBookPro M1 that just started showing this problem. Big Sur 11.2.3 installed.

The USB flash drive will no longer auto mount. It loaded once, I could see the files, clicked on a file and the computer ejected the external drive. I cannot see any external drive, tried rebooting, disk utility without any success. The drive was created not long ago prior to Big Sur. I have critical files and think is related to what you all have posted. I cannot reformat drive. Need help, any other suggestions?
Big Sur - external discs not mounting