iOS 14.3 simulator with a yellow navigation bar color.

Hi all

Anybody knows why I'm getting a weird yellow color in the navigation bar and the tool bar?.
Simulator with iOS 14.1 it looks good, but iOS 14.3 looks with the yellow color.
I disabled all the option in the Debug menu -> Color options...

Thanks!

Solved Answer

I fixed it:

1 - In the simulator, set "File > GPU Selection > Prefer Integrated GPU" to workaround this bug.
2 - Restart simulator.


found the answer here:
https://stackoverflow.com/a/65304354/4483716


17 Replies

I fixed it:

1 - In the simulator, set "File > GPU Selection > Prefer Integrated GPU" to workaround this bug.
2 - Restart simulator.


found the answer here:
https://stackoverflow.com/a/65304354/4483716


Thanks! It's help.
Thanks I thought I was the only one with this problem.
The fix does not work on iMac with Big Sur.
I have an iMac (Retina 4K, 21.5-inch, 2019) running macOS Big Sur v 11.1. Changing the GPU preferences did nothing. None of the settings fixed the problem.
I have gone back to using the iOS 13.6 emulator. The yellow is just too much
I have the same problem. I have an iMac 4K 27 inches 2019. The yellow bothers me so bad!.
Same issue found on Xcode 12.3, OS Big Sur, iMac.
The Main.Storyboard also shows the same yellow background for navigation bar and tab bar.

Any solution to this?
Especially boring when you're trying to generate a lot of screenshots with fastlane
i have issue with navigatorbar margin of left and right with 14.3 and ipad8a or ipadpro.. with 14.2 works fine
I have these yellow background symptoms with swiftui's standard .alert popup. use to be a popup with a white background now changed to yellow.
When will this be fixed???
Same problem on iMac with Catalina.
Workaround seems to work, waiting for a fix !
No interest in having a dedicated graphic card otherwise...
I'm also having the same issue. I'm on Big Sur with xcode 12.3 and the bars are yellow