Can you remove Rosetta 2 on Apple Silicon?

I need to test my installer on Apple Silicon, and I have previously installed Rosetta so I no longer get the prompt to install Rosetta.

The Mac mini and Macbook Air M1 that were ordered came with 11.0.1 and 11.0.0 respectively. The mini didn't have Rosetta and Air is pre-installed.

Short of reinstalling Big Sur on the mini M1, how can I delete Rosetta 2?


Post not yet marked as solved Up vote post of wibw Down vote post of wibw
16k views

Replies

It is the same thing I have tried to do on my M1 Mac mini, since I don't want to use Intel executables, but after my research I have discovered it is probably not possible at the time...
The reason is that Apple seems to be using Rosetta for some of their services ... For example Apple Music is using it, with process name: VisualizerService-x86(Music), it is actually the only Intel process running at the moment on my system.
I have to notice that their claim that all Apple software was already ported to Apple silicon was false... That's bad.

How do you know that you don't have rosetta on the Mac mini ? How did you check ?

Is the command:

Code Block
arch -x86_64 bash


working?
@aleroot, on a freshly installed 11.1 (20C69) on M1, that command returned "arch: posix_spawnp: bash: Bad CPU type in executable". So, Rosetta is not present in 20C69.

One simple check I did is to fire up our older version of our installer where I haven't added arm64 to the optional hostArchitecture in distribution XML. If Rosetta is not installed, the OS will request that I install Rosetta.

I can also use a script from Der Flounder and modified it just to check.

For example Apple Music is using it, with process name:
VisualizerService-x86(Music)

I suspect that this process is running in order to host an Intel iTunes visualiser plug-in. While iTunes visualisers are way outside of my area of expertise, I’ve seen similar things with other plug-ins.

Share and Enjoy

Quinn “The Eskimo!” @ Developer Technical Support @ Apple
let myEmail = "eskimo" + "1" + "@apple.com"
I'm looking for the same answer.

I need to verify that our website can handle an error message correctly when Rosetta isn't installed.

(Related to the Widevine dylib of Chrome not yet being available as Apple Silicon version).

I have found no way to disable Rosetta completely, disable it only for the specific dylib, or uninstall Rosetta.
Only solution so far is to reinstall macOS...

Any advice would be highly appreciated.

I also need to remove Rosetta to test a launch problem with my app on an M1. I burned an Apple Technical Support ticket and was basically told that Rosetta can not be removed once installed. They suggested that I "use a VM for this sort of testing", but I don't know of any VM that could work for this (not to mention the hassle). Sigh.
How can i remove/disable VisualizerService-x86(Music) i think is not needed, this is a plugin for Music.app ?

When I run from CLI kill -9 PID of VisualizerService-x86(Music), Music.app still work fine on M1 :)
I can't delete this from Music.app, xattr -d or simple chmod don't help :/

/System/Applications/Music.app/Contents/XPCServices/VisualizerServicex86.xpc/Contents/MacOS
sh-3.2: mv VisualizerService
x86 VisualizerServicex86.off
mv: rename VisualizerService
x86 to VisualizerServicex86.off: Operation not permitted

sh-3.2: id
uid=0(root) gid=0(wheel) groups=0(wheel),1(daemon),2(kmem),3(sys),4(tty),5(operator),8(procview),9(procmod),12(everyone),20(staff),29(certusers),61(localaccounts),80(admin),702(com.apple.sharepoint.group.2),33(
appstore),98(lpadmin),100(lpoperator),204(developer),250(analyticsusers),395(com.apple.accessftp),398(com.apple.accessscreensharing),399(com.apple.accessssh),400(com.apple.accessremote_ae),701(com.apple.sharepoint.group.1)
Hi,
is there a way to uninstall Rosetta? Because I really like to test some updates to the pkg that we made.
Our problem was that we didn't specify the hostArchitecture and therefore Rosetta was installed. Now that I set the hostArchitecture I wan't to double check that our pkg doesn't prompt the Rosetta popup again.

As a Developer I really want to have the possibility to reset the Rosetta Support. Preferably without a factory reset...
Hi all,
I did find a way to remove Rosetta again, but it involves the Recovery because the files are SIP Protected.

  1. Obtain a list of files/directories and LaunchAgents with: pkgutil --files com.apple.pkg.RosettaUpdateAuto

  2. Save them in a way that you can access them in the recovery

  3. Boot into recovery

  4. Make sure your disk is mounted

  5. delete the files from Disk

  6. reboot

I don't list the files here as the list might change with a later version of Rosetta.
I hope this helps everyone who is in the same Situation as I was.

Best Regards
Timo

Add a Comment

Thanks @BoBKelso! To add up to your answer, steps 4 and 5 weren't clear to me, so here is what I did instead:

  1. Obtain a list of files/directories and LaunchAgents with: pkgutil --files com.apple.pkg.RosettaUpdateAuto
  2. Save them in a way that you can access them in the recovery
  3. Boot into recovery
  4. Open terminal in recovery (btw to load recovery on M1 macs you long press the power button instead of holding CMD+R)
  5. Run csrutil disable and confirm (temporary disable SIP)
  6. Reboot
  7. Delete the files listed at step 1 (in my case it was enough to delete/Library/Apple/usr/share/rosetta and /Library/Apple/usr/libexec with all their contents)
  8. Reboot back to recovery terminal
  9. Run csrutil enable and confirm
  • That was very helpful, thanks!

  • I tried using the csrutil in terminal, but to no effect. I am still getting the same error message.

Add a Comment

User

My name

I'd really recommend doing this sort of "fresh system" testing in a virtual machine. Thanks to Virtualization.framework there are a few cheap or free options, such as https://github.com/KhaosT/MacVM , https://apps.apple.com/us/app/utm-virtual-machines/id1538878817?mt=12 , and https://apps.apple.com/us/app/virtualos/id1614659226?mt=12 . It's a little slow but you can be sure that the OS install is totally fresh, very much like what you would expect a customer with nothing installed would have.

Building on answers by @kyrsquir and @BoBKelso and saving a few reboots.

  1. Reboot into Recovery Mode
  2. Mount of the Data partition using Disk Utility
  3. Open Terminal
  4. Use pkgutil to figure what was installed where on the now mounted Data partition, e.g. pkgutil --files com.apple.pkg.RosettaUpdateAuto --volume /Volumes/Data
  5. Remove Rosetta files from mounted Data partition
  6. Reboot
  7. Verify in Terminal, e.g. whoami on x64 arch should say:
% arch -x86_64 whoami
arch: posix_spawnp: whoami: Bad CPU type in executable