Missing signing identifier at UnityFramework.framework/Frameworks/libswiftCore.dylib"

Hi,Guys!! I am useing Unity build my ios project, builds and running in xcode without any issues. But,when i use 'archive' excute build and submit to app store, An error has occurred in xcode, prompts me 'Missing signing identifier at libswiftCore.dylib' I used the follwing librarys. Firebase,Applovin,StoreKit,AppsFlyer,AuthenticationService.framework

I've searched many sites,but i can't find any help. Please give me some advice

Thanks a lot !!!! Thanks a lot !!!! Thanks a lot !!!!

Missing signing identifier at "/var/folders/qz/fqrs14ws2737g8jpqysndqqw0000gn/T/XcodeDistPipeline.~~~zYHleI/Root/Payload/8BallKing.app/Frameworks/UnityFramework.framework/Frameworks/libswiftCore.dylib".

Failed to cloud sign "/var/folders/qz/fqrs14ws2737g8jpqysndqqw0000gn/T/XcodeDistPipeline.~~~zYHleI/Root/Payload/8BallKing.app/Frameworks/UnityFramework.framework/Frameworks/libswiftCore.dylib". Please file a bug report at https://feedbackassistant.apple.com.

Replies

Have you solved this problem

Set Pod package Enable bitcode = NO to YES

Any one solved this problem, i have same issue, hapend only one project, another project still working god.

Had the same issue, in my case the distribution certificate was expired. You can let Xcode create one by choosing to manually manage signing, select distribution certificate and + or you can add it using developer.apple.com dashboard. Hope this helps.

I solved in a weird way.

In xCode, go to general tab and in Target > UnityFramework > Frameworks and Libraries remove the AVFoundation.framework and add it again with the + sign...

No need to set min target to iOS 15

Now if you Archive again the package and try to submit the error is magically gone away.