Undefined symbols for architecture arm64 in Xcode 14

I am facing an issue when building a project that builds without issue in Xcode 13.4.1, but hits a build error in Xcode 14. Specifically, this project uses CocoaPods and references a specific pod, "AdobeMobileSDK". In a sample project where I can replicate this issue, my Podfile looks like;

target 'AdobeTestProject' do
  # Comment the next line if you don't want to use dynamic frameworks

  # Pods for AdobeTestProject
  pod "AdobeMobileSDK"

I receive a build error reporting;

Undefined symbols for architecture arm64:
  "_OBJC_CLASS_$_ADBMobile", referenced from:
      objc-class-ref in ContentView.o
ld: symbol(s) not found for architecture arm64
clang: error: linker command failed with exit code 1 (use -v to see invocation)

After digging around a bit, I'm noticing that in Xcode 13.4, during the linking phase, Xcode issues a command that includes -lAdobeMobile. However, in Xcode 14, this is not the case. If I manually add -lAdobeMobile to the Other Linker Flags in my project settings, I can resolve this error, but this workaround is not suitable for all use cases (in a more complex project, adding -lAdobeMobile does not rectify the issue).

I recognize this is likely some influenced by the SDK itself, but is there any documented change for Xcode 14 that would cause this build error only in Xcode 14 and not Xcode 13.4.1? This issue occurs regardless of whether Xcode 14 is running in Rosetta or not.

Post not yet marked as solved Up vote post of brandonK212 Down vote post of brandonK212
  • xCode 14 suppressed support for 32 bits devices

Add a Comment


Same problem, no solution at all

I found the solution. Just change the architectures to srmv7k. Then build success!!!!! This question has been bothering me for a week

-lAdobeMobile worked for me. Thank you @brandonK212

@brandonK212 thanks, confirm adding -lAdobeMobile  to Other Linker Flags worked for me too

Glad to hear this worked for so many! All credit goes to my co-worker who discovered this. Glad it helped others!

  • error build: Library not found for -lAdobeMobile

  • @A000ANB I'm getting the same error. Did you find a solution?

Add a Comment

Wow! Amazing! worked like a charm! Thanks a lot!