High Sierra Installation on Existing RAID 0 Array

Hello,


I have the development beta of macOS 10.13, however I cannot install the upgrade because of the SSD RAID 0 I set up earlier this year to increase R/W speeds. The exact error message from the installation utility is "You may not install to this volume because it is part of a AppleRAID."

It is a software RAID done through Disk Utility on a MacBook Pro 9,2 with 2x Crucial MX300 275GB SSDs. I remember I had to create two separate partitions from each of the two drives, and RAID two of them together as a main drive and the others as a recovery drive in order for the operating system to install.

I am currently running Sierra, and the only other modification the laptop has is a memory increase (4GB to 16GB).

I would like to preserve my files in the same fashion as a regular installation of a new OS onto a single drive system. What would be the easiest way to do this? I have access to two 1TB hard drives I could RAID together to use as a backup system, and do a clean installation of High Sierra, and then transfer over the files from before. This is a bit tedious, and I am unsure about how to do this with a beta software which can't be pulled from the online recovery system during startup. So, if there are any more convenient ways to go about this issue, I would really appreciate the advice. Thank you!

Post not yet marked as solved Up vote post of CBCCool30 Down vote post of CBCCool30
36k views

Answers

Same situation. Any luck?

Not yet. I backed it up and tried to reformat the drives to APFS, but for some reason the RAID always failed or showed up offline, or even created new partitions that were completely unformatted. I eventually just reinstalled Sierra on my original Mac OS Extended (Journaled) RAID 0 setup. I don’t think APFS likes software RAID much... if you figure anything out, let me know.

Same here. I've tried all possible scenarios. APFS/RAID0; fails. EJ/RAID0; Successful, but install fails. I was able to format one drive (EJ), and install; but, what's the point? I'm reverting back to Sierra, until a future release becomes available.

RAID install fails but restory from TM backup work. I have created RAID 0 APFS Continer with inactive volume, I added next volume and I deleted 1 inactive. Then I restored the system(10.13) previously installed on a single disk.

https://snag.gy/dS0sAl.jpg

I have the same issue. Mac Mini Server with all original hardware. Will not install with RAID0 or RAID1 in any format available in 10.12. 10.12 installed just fine. Reported as a bug.

This is the longest I have ever seen a macOS bug report sit idle without any response at all.

Hi reel! Can you give more details about how you created the APFS RAID0 volume? Thanks!

The latest build does not seem to fix this issue.

Has this been fixed yet?

Doesn't seem like that.

I think it has something to do with APFs and the software controlled RAID.

Maybe there has to be a special APFs-RAID if it's software controlled, so the copy charasteristics can be handled.

This may cause a new RAID management system, that is not compatible with previous software RAIDS

I finally received an official response from Apple on the bug report. No 10.13 installs on Apple RAID volumes.


"...this looks like correct behavior...we stopped allowing installs to RAID set members in macOS 10.13"

I have a Raid 0 with two 512 GB SSDs in my Mac Mini (containign everything, system files and data). What does this mean for me? Will i be able to upgrade to High Sierra? Or worse: Will it let me upgrade just to not to be able to read my SSDs?

I found this on Apple's Website


https://developer.apple.com/library/content/documentation/FileManagement/Conceptual/APFS_Guide/FAQ/FAQ.html



"Can I boot macOS High Sierra from an APFS-formatted hard disk?

Yes. macOS High Sierra supports Apple File System for both bootable and data volumes."


"Can RAID be used with Apple File System?

Yes. Apple File System does not directly implement software RAID; however APFS-formatted volumes can be combined with an Apple RAID volume to support Striping (RAID 0), Mirroring (RAID 1), and Concatenation (JBOD). APFS-formatted volumes can also be used with direct-attached hardware RAID solutions."

as of today's build still cannot install onto RAID

I think I just beat it by simply not installing directly to the RAID partition but restore it. I partitioned a fresh partition for 20GB. Install HS to it. Reboot, boot up with a usb, and then use disk utility to restore the partition to the raid partition. Whoa it boots!


Edit 1: It is HFS+ not APFS at the moment. Im trying to investigate on APFS.