iTunes 12.7 Play Count and Last Played No longer updating

Anyone else getting this frustrating error? Since iTunes 12.7 when you play a track in iTunes or via Home Sharing the Play Count is not incrementing and the Last Played Date is not being changed.

However if you play a track on your iPod/iPhone and sync the track you played on that device is updating the Play Count/Last Played.

Seems quite a few users are getting this error. Some didn't have the error and have suddently started getting it in the last couple of days....

Any ideas?


Yes, I am having the same issue. I've also seen at least 30 other people raise this issue with Apple.

Yea, this just showed up yesterday with the new version installed. Crossfading changes didn't help. I never used cross fading anyway. I did have both a iPhone 6 and and an iPhone 4 which I simutaniously had connected to iTunes via WiFi. I think that caused other problems, like songs that were played on the device were not syncing, and unplayed in the same album could not be played on the device. The 4 is now working OK, with a complete reload of music. Still trying to resolve iphone 6 sync issues.

Turns our iPhone 6 does update playcounts. Only playing songs in itunes on my PC (Windows 10) has stopped incrementing - no last /updated played date.

Hoping for a quick fix from Apple as I stream all my music at home using iTunes on my Apple TV. The play counts are not updating for Home Sharing either.

Soltution. De-authorise your iTunes from your PC, sign out. Re-boot. Re-authorise and sign in. Fixed.

Thanks man this worked for me. Was slightly frustrated but this solved my problem really quickly! 🙂

Worked for me too but just to clarify, after re-authorizing your computer you need to sign out, then sign in again.

This does solve the problem, but if you then try to reconnect with iTUnes match, to sync your orther computers, the problem reappears. It means that to record counts the PC has to be out of ITunes Match, so losing all the songs stored on other PCs or laptops in your network.

I have this problem too!! Tried deauthorizing signed out, signed in.. Nothing. Played a song (complete playback until the next one) and the counter stayed at zero. Apple broke iTunes again.

Same. Not fixed since official release. No Last Played or Play Count update whether played on Mac or iPhone. Sigh …

Thanks XRayLexx. The solution worked for me. The occurrance happened to me yesterday after syncing my new iphone with old phone data via itunes. Anyone else doing this method of transferring data, please beware and follow the instructions from XRayLexx. Thank you.

As iOS 11 is now public, user-centric queries/comments such as this are perhaps best put to Apple's public community support forums, run by AppleCare, and/or Apple's twitter support account, vs. risking off-topic here in the DevForums, thanks and good luck.

Users can feedback via - Individuals using betas are free to use the Feedback Assistant; devs can use the 'Report Bugs' link, below right.

I too have had the same issue, I’ve found it to be a problem since the first or second bug Sierra beta.

Boom. Worked for me, after de-authorizing, re-installing, authorizing, de-authorizing, and authorizing again

I have just noticed I am having this issue as well. Play count only updates when played on iPod, and not on PC. Haven't tried some combination of deauthorising and reauthorising yet because I'm in the middle of something, will report back if I fix it.