el capitan icloud login unknown error

I have MacBook Air (13-inch, Late 2010)

10.11 Beta (15A215h)


I just updated to El Capitan. and when I finished updating,


icloud says I need to put my password again in order to use my icloud account.


So I filled my password. however, it does not log in, spinning gear keeps spinning and when it's done, it says


'unknown error occurred'


I tried many times and I just cannot log in,


I thought maybe next update can fix this problem. so I checked for an update on Appstore account.


And I can not log in to my AppStore. it says the same thing. 'unknown error occurred'.


How can I fix this problem?


I tried logging out and log in again but it does not work either

Post not yet marked as solved Up vote post of csi2586 Down vote post of csi2586
64k views

Answers

Same Problem.

also having that issue i even reset my apple id. No dice.

actually mine says the pw is incorrect even tho i know for sure i typed it in right

Same problem

MacBook Air 13 - 2014


I tryed the app specific generated passwords, a account reset, but no result 😟

Same here on iMac (late 2012); have 2-factor ID. changed password etc. no change. Works fine on IOS9..

Same problem. Buy i can access everywhere and every service through Safari login.

I had the same problem, and it "went away". I tihnk the issue was resolved by logging out of iCLoud and back in, but honestly I can't say for sure. I was somply going to wait until an update fixed it, and each day I fiddled a little and I think it resolved itself when I logged out of iCloud and back in.

FWIW: Logging out and back in on iCloud did NOT work for me.

https://forums.developer.apple.com/message/9396#9396



The answer is the response on that thread. Just fixed it for me.

ssame problem - preference pane hangs when I try and sign in.

I had the same problem for like a month. I reinstalled, rebooted, removed some pref-files. Nothing helped.

Other accounts were able to log in so I finally tried to turn off two-steps-verification (which I had enabled and the other account did not).


This helped for me.

I had exactly same problem, i tried reinstalling El capitan several times, it did not worked out, however strangely enough it worked out by accident.


this is howe it worked out for me:


i restored the machine to previos time point (before El capitan, i. e. Yosemite) using Time machine restore.


The i restore again to El capitan, again using time machine back up. After complete restore, it asks to set up the iCloud, there you should put your login details. Then it worked out perfect, all my apps using information from the iCloud were sync flowless.


The issue is most likely not not doing iCloud set up when system ask ( i.e. Do it later, this option was selected and the i cloud was having error message.)

So do not avoid iCloud setup, as i learned.


its time consuming to perform two complete restore, but it fixed the issue.


I wish you all the best.


Cheers!

Same symptoms here, except the gear keeps spinning forever and I have to force quit the app.

Happening on any app relying on apple ID:

  • iTunes, App Store, iCloud (system preferences): sign in window hangs, spinning gear
  • FaceTime: Clicking "sign in" does nothing

There is nothing to delete in ~/Library/Application Support/iCloud/Accounts.

I had the same problem.


Previously, I was never able to login to use iMessage from my desktop Mac, but basically ignored the problem (used my iphone). After El Capitan, I was not able to access iTunes or iCloud at all.


I did notice that I was missing a serial number on my computer (from Finder, go to About This Mac). Somehow my serial number got wiped when I took my Mac in for a hard drive exchage (recalled under warranty).


This webpage showed me how to reinitialize the serial number (etched onto the footplate of the Mac chassis). It's moderate difficulty, but not impossible. The trickiest part was getting disk utility to actually burn the Blank Board Serializer to CD. After that, very simple and after restart, everything works!


http://rogersm.net/icloud-problems-mountain-lion-serial-number


Hope this helps anyone missing a serial number!

I had the same problem. I tried many things including deleting files in icoud/Accounts, restarted holding command-option-PR for 2 bongs, shut down machine and booted up after 10 seconds, booted off another drive and ran disk tools... Even spoke to 2 different Apple reps. No dice. After they elevated and said an engineer would contact me in 48 hours (too long) I went old school.


I restarted my machine, holding down the shift key. Safe mode. Logged into itunes, icloud and messages with my apple ID... NO PROBLEM! Restarted my machine normally and Víola!