Can't login to App Store under Catalina

The App Store app is logged out, and logging in with the correct credentials spins for a moment then leaves the app without being logged in.


As of now I'm suspecting a filesystem issue, perhaps permissioning, as I've seen other things that might point that way.


Anyone else seeing this?

Accepted Reply

All preference panes requiring authentication fail for me, so the solution of logging out of iCloud through Preferences didn't work for me.


What did work was logging out of the Music app, logging back into the Music app, then logging into App Store.


Hope this (or the Preferences variant) helps others.

  • This worked for me as well in February 2022. Surprised this hasn't been fixed yet.

Add a Comment

Replies

same for me

I have the same exact issue and have not found a resolution.

I have an Apple ID that I use for iCloud, and another that I use for the App Store (and everything else). My attempts to login with my main ID failed, but it succeeded using my Cloud ID. I then logged out of the App Store, and was able to login using my main ID. I did get prompted a couple of times, but the second login with my main ID worked. At some stage I also had to authorise the computer.


Pretty certain I got the login credentials correct always because I’m using a password manager. At this stage I’ve not had any updates, so can’t be 100% sure the App Store is fully functional.

same for me

Had the same issue. Reinstalling Cataline helped me but the problem occured again one day after. No real solution until now.

Same problem here, I could not log in using my main iCloud account (Apple ID). Interestingly, i was able to login using an alternative account linked to the Swedish App Store. From there I logged out and was not able to login to using my main iCloud account credentials. Let's see if the problem re-occurs.

Same problem for me. I submitted feedback using the Feedback app.

I was able to log in, but some apps downloaded from the store are not authorized to run. After an authentication dialog they show as damaged.

Same here.. I enter my Apple ID password, click Sign In and nothing happens. It appears like I didn’t even try to login.


If I try to download a free app, I get prompted to enter my password. I enter my credentials and nothing happens.


I haven’t had any app work.

Same issue here, enter Apple ID password and nothing happens when you click Sign In.

Also noticed that 2 Factor login not working on other system running Mojave.

Checked account setting on Catalina in system preferences and 2 Factor login is turned on.

Also cannot download updates automatically from Appstore

For me, I went to my settings app, signed out of my iCloud account, waited a minute and then signed back in. Then, I restarted the Mac app store app and was able to sign in and get my app updates. YMMV

I did the same thing you suggested: log out of icloud, log back in, the app store is now online and shows me logged in.

It was an arduous procedure with a number of error messages, but I managed to sign out of my Apple account on my Mac. Signing in again did in fact allow me to sign in to the App Store and update apps, etc. Thanks!

Same problem. Can't update or purchase on Mac, though no problem doing so on my phone or iPad also running betas.

Same issue, I cannot login with my iCloud account, however my other Chinese app store account works for some reason.