App unable to import files in iOS13

My app has the ability to import GPX route files. However I am getting reports from users of iOS13 that the app is no longer appearing in the list of available apps when they try to export a GPX file.

Has anyone else seen or heard of this, and does anyone know how I might get around it? As far as I know it is only the Imported UTIs that affect this - is iOS 13 more fussy about how they are specified?

  • I want the experience.

Add a Comment


Did you get to the bottom of this? I also have an app that exports UTIs, but on iOS 13 when opening an appropriate url Safari uselessly offers to download the file rather than offering the usual "Open with" dialog.

It sounds like a similar problem.

Same issue here. From all the documentation, I believe my exported types are correct. Opening a supported file from the 'Files' app launches my app, but my app doesn't appear in activity controllers, nor can I open files 'shared' through messeges, etc.

I haven't worked out a way around it yet but when I uploaded my last beta I did get a warning about LSHandlerRank needing to be set on my document types. I had it set for the GPX document type but not for a couple of other types, so maybe you cannot import any types if some of them do not have this key set?

It was only a warning and I haven't been able to test this theory because I didn't want to immediately release another beta with a new build number, so I won't be able to test the theory until my next beta. I will probably also set CFBundleTypeRole as well because that seems to be associated with LSHandlerRank.

Apologies if this is a red herring but I thought I would mention it in case it helps anyone else.

Doesn't seem to be LSHandlerRank or CFBundleTypeRole as I have those set already.

Still a mystery why this doesn't work, but am hoping it will be fixed (or at least some documentation on it) in a future beta of iOS13.

I spend a code level support item on the issue. It’s a bug. The response I received was a request to file a bug report, I’d suggest the same.

Thanks for the info, yeh, I thought it must be a bug so in the end I filed a bug report (a few days ago). Haven't heard anything back though.

Are you sure it's not buried deep in the share window? There's a Manage ... on the bottom that hids a ton of stuff. It's really a lot more cluttered now despite having the redesign.

In my case, it's not a problem of being buried. My application can share things just fine. It can even be opened by those shared things... unless they are in iMessage. I'm comfortable with it being a bug, given that code level support couldn't find anything amiss with my code. I appreciate the offer of the assist though.

Has anyone found a way around this yet? I just tried beta 8 and it is still not working, so I am worried that it will not be fixed for the release.

My radar is marked with "Recent Similar Reports: More than 10" ... so we know they are aware of it at least.

Thanks for that. As is common I can't currently log in to Feedback Assistant to check the status of my radar but hopefully it shows the same.

Has anyone tried it on the iOS 13.1 beta yet? I have only got 1 test device, which used to be enough, but Apple seem to be going beta-crazy this year!

Also doesn't work on iOS 13.1 beta 1 😟

That's a shame. Thanks for letting us know.

I have added a workaround to my app in the form of an Import button that displays an instance of UIDocumentPickerViewController. It isn't as good as being able to share a document to the app, but it does allow users a way to import documents that works on iOS 13.

Someone on another thread ( has spotted that the existence of other apps that have registered an interest in the same type could be the cause. I uninstalled several such apps and suddenly my app appeared on the share list. I then reinstalled the apps and it is still on the share list.

It seems inconsistent, but maybe knowing this may help us to work out what is going wrong.

Subscribing the thread for facing the same annoying issue. In the meantime I'll have to resort to the UIDocumentPickerViewController trick too (@cfc good call on this). More development time wasted to have a degraded app functionality.. and I foresee user complaints. Gosh, I'd better say nothing.

BTW I also filed a report a few days ago, but the bug has really been around since June. I had hoped that they could realize by themselves due to how blatant it is.

Let's strongly hope they don't release GM with such a shameful bug.