iOS 9.2 Unable to install managed app from MDM

After upgrading to iOS 9.2 managed apps are failing to install. We are seeing the following error message in the device logs:


12/9/15, 1:53:07 PM mdmd[661]: (Note ) MDM: App “[app.bundle.name]” state changed from Prompting to Failed.


Anyone else seeing the same issue?

Accepted Answer

iOS 9.2.1 was released today at 10am PST. From the testing I've been able to do this has resolved the issue which is the same result I saw using the beta version.

Answers

Yes, we are seeing this across multiple MDM platforms, noticed that we can't still manually install via the "corporate" app store from MDM as a work around. Follow our testing here: https://emm.how/t/unable-to-push-managed-app-s-to-apple-ios-9-2-devices/87

We are having the same issue.

Were you able to find a solution? It appears that this iOS 9.2 update has broken our ability to manage and download apps from our Cisco Meraki MDM deployments.

We are seeing the same there here - Managed apps won't deploy since the upgrade to 9.2

Seeing this here too. If this is affecting all mdm suppliers hoping Apple release a fix/update soon, this seems rather a severe oversight as it potentially affects every enterprise managed device out there....

I can confirm we are facing the same issue. Citrix XenMobile 9 and 10.

No solution other than advising our enterprise users not to upgrade to 9.2. We're also seeing crashes related to the mdmd process which causes devices to fail to check-in. We're using MobileIron and their community forum is full of other customers reporting the same issues.

I can confirm that we also have the same issue with MobileIron.


After some investigation, it looks like there is a bug in the way Apple Store the Cookies for the HTTP(S) session related to the binary download which results in a Segmentation Fault on the device. So nothing we can do and unfortunately need (again) to wait on Apple to fix it.


Note that the first time a managed application is installed, it's working perfectly well. As soon as we try to install any other managed application, it's not working anymore.

I can also confirm the same issue with MobileIron.

I may found a workaround for this. It is not user friendly but it works:


1) Un Enroll the device

2) Uninstall and Install Worx Home again

3) Enroll the device


I did this with XenMobile and it worked.

Tried this on MobileIron but no luck. After device is retired and setup as new device there is no check-in happening so setup does not complete.

Any word from Apple on this issue?

IBM put a workaround in place for MaaS360 and seems to be working.

Any idea what the workaround was?

We encounter the same issue with XME 9.0 + latest apps on iOS 9.2


The workaround you outlined works for our iPhone 5 and an iPhone 6. On the iPhone 6 we were able to just click "re-enroll" in the menu in WorxHome. This solved the issue on this device or device class.


Our iPad reacts in a different way. This is an iPad 4th. generation (A1460). Here we tried (1.) to "re-enroll" like we did on the iPhone: failed, (2.) removed all apps incl. WorxHome and tried to re-enroll: failed, and even (3.) re-tried the 2nd attempt and additionally removed the device from the DevMgr before we launched th re-enrollment process: failed.


I don't know whether the iPads are really behaving differently or if this is a single occurrance just with our device.


Anyone able to read the debugging info you get when you connect an iOS device to a Mac and launch XCode? Any hints or ideas?