tvOS14 Audio Output Sources Missing

tvOS14 has no option to choose an output source so No Airplay to homepods. Has the Option moved or been removed from this version? I see nothing about it in the release notes
Post not yet marked as solved Up vote post of pacman Down vote post of pacman
9.2k views

Answers

You should still see it under Settings -> Video and Audio -> Default Audio Output.

If this doesn't work try bringing up the control center by holding down the TV button, and then press on the AirPlay icon.
Thanks for the advice your first suggestion no such option appears for Default Audio Output on my apple tv 4k model A1842 (64 GB) using tvOS14 beta

However your second option provided a suitable work around by holding down the TV button

So thanks
  • Workaround worked but I feel like if Default Audio Output was available, the TV wouldn’t turn on to show what I’m listening to on Apple Music. 😃

Add a Comment
It was hinted that tvOS 14 would allow for Default Audio Output.

I stream Netflix and listen the audio via my HomePod

If i use another device for listening some other kind of audio on my HomePod, I lose my audio output on the Apple TV

I then need to manually reset my apple TV's audio output setting to the HomePod.

A Defaut Audio Output would be appreciated.
I'm on the latest Apple TV beta and the latest iOS 14 Beta 3 just released and there is no " Settings -> Video and Audio -> Default Audio Output". Also don't see the option on iOS in settings, or in home > Homepod > settings or home > appletv > settings. In other forums others all note it's missing yet some do see it.
  • I’m on 14.6 and still don’t see it. Maybe it’s one of those plans that they WANT to do it. 😃

Add a Comment
Am seeing this problem with tvOS 14.2B3.
I finally see the Default Audio Output option but it still only shows TV Speakers as the selectable option. However the workaround of using the TV (Home) Button on the Apple TV remote still works and I can select the HomePods but defeats the purpose of Default if you manually have to do this every time. It is still unclear to me why they dont appear under the Default Audio Option as I have an AppleTV 4k its running the latest TVos release the HomePods are running the current iOS 14.1 as there is no other update to apply. I am not sure if there is any smarts behind Default Audio Output if it checks your Region for example and assumes since mine is set to Netherlands that it concludes since Homepods are not sold in NL they are not available for selection. I bought my HomePods across the boarder in Germany. The language settings on both HomePods and the AppleTV are both set to English as I am an expat and speak zero Dutch
Just updated atv4k. HomePod is also update and there’s no ability to select it as the default audio source... only TV speakers. This update has actually managed to make using homepods with Apple TV worse. Nice work
Add a Comment
Update - looks like homepods and atv have to be in the same room in HomeKit for this to work
Same error since I update to version 14.2 18k57... it is urgent we can’t select our soundbar as before.

Same problem - default audio output menu only lists TV speakers. Workaround posted by pacman thankfully worked: TV home button long press —> airplay menu.

so this is still a problem. And add to that that the YouTube app audio is still getting cutoff 1 second into video playback. Extremely frustrating.
Has this been fixed I'm havign same issue where I updated one of my apple tv boxes to new version and I can no longer see my sonos speakers and only see tv speakers, basically rendering my sonos speakers for my TV useless

On my other apple TV which I have not updated I still see my sonos speakers and can use them as audio output

this is a big issue is it going to get resolved?
  • Did you figure this one out for your Sonos setup?

Add a Comment
This HomePod implementation killed all the other AirPlay speakers!

I cannot longer select my HK Citation 500 under de Default Audio Output setting!

Is this on purpose? So we have to buy Apple Homepods? Or is it a bug? It worked last week when bought my speaker!
Same with Bose soundbar 500.

Before last update I could select it in the "default audio output" list and that way it auto connected whenever I turn the tv on.

Now I have to connect it manually every time trough either Bose app or settings in the AppleTv menu.
And even then it auto-disconnects if for some reason I don't have anything playing for a while.
OK ... I freely admit that I'm not the smartest cookie in the jar, but there's something I'm not getting here with this workaround.

Since my Apple TV has updated itself to tvOS 14.2, I've lost all ability to connect the Apple TV with the Homepod stereo pair. There is no 'Default Audio' option under 'Video and Audio' ... it just doesn't exist. And when I press and hold on the Apple TV icon, the only options I get are to create a new folder. What am I misunderstanding? It was all working fine until this update.
Some people have reported this, but the Default Audio Output should still be there! And it is for most people. In fact, if you’re using Homepods, you should be able to select them form there without a problem, that’s the only speaker supported right now.

You need to have all your devices updated to the latest versions, and then use your iPhone Home app to set it up, if the AppleTV doesn’t let you.

The workaround is with your remote, not there AppleTV logo. In your Apple TV remote just hold the “Home” button, the one that looks like a TV. A menu will pop up on screen and in the bottom left you can select your speakers.
  • That’s the workaround for sure. Kind of ridiculous. I’m on 14.6 and they still haven’t fixed this issue. I also let Apple do all the heavy lifting and let it set up automatically. The most annoying thing is it made its own Home in HomeKit. So I had to move my HomePods to the “new” Home created by the Apple 4k 2. Annoying. 😃

Add a Comment